7-5 圆形体体积计算器 (20 分)

本题要求实现一个常用圆形体体积的计算器。计算公式如下:

  • 球体体积 V=34​πr3,其中r是球体半径。
  • 圆柱体体积 V=πr2h,其中r是底圆半径,h是高。
  • 圆锥体体积 V=31​πr2h,其中r是底圆半径,h是高。

输入格式:

在每次计算之前,要求输出如下界面:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:

然后从标准输入读进一个整数指令。

输出格式:

如果读入的指令是1或2或3,则执行相应的体积计算;如果是其他整数,则程序结束运行。

  • 当输入为1时,在计算球体体积之前,打印Please enter the radius:,然后读入球体半径,完成计算;
  • 当输入为2时,在计算圆柱体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算;
  • 当输入为3时,在计算圆锥体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算。

计算结果在一行内输出,保留小数点后两位。

输入样例:

1
2
3
2.4 3
0

输出样例:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius:
33.51
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius and the height:
18.10
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:

 Warning!:题不难,但这个题的圆周率居然要精确到后十位也是给我整神完.........

代码如下:

#include<stdio.h>
#define PI 3.1415926535
/* Author:海蓝可知天湛
   date:2022-3-1
   location:居家隔离(´。_。`)........
*/
void menu(){
    printf("1-Ball\n2-Cylinder\n3-Cone\nother-Exit\nPlease enter your command:\n");
}
//菜单界面可视化
void Ball(double *ans,double r){
    printf("Please enter the radius:\n");
    scanf("%lf",&r);
    double v=4.0*PI*r*r*r/3;
    *ans=v;
}
//球体类
void Cylinder(double *ans,double r,double h){
    printf("Please enter the radius and the height:\n");
    scanf("%lf %lf",&r,&h);
    double v=PI*r*r*h;
    *ans=v;
}
//圆柱体类
void Cone(double *ans,double r,double h){
    printf("Please enter the radius and the height:\n");
    scanf("%lf %lf",&r,&h);
    double v=PI*r*r*h/3;
    *ans=v;
}
//圆锥类
int main(){
    int a=1;
    double answer,r,h;
    while(a<4&&a>0){
        menu();
        scanf("%d",&a);
        switch(a){
        case 1:Ball(&answer,r);printf("%.2f\n",answer);break;
        case 2:Cylinder(&answer,r,h);printf("%.2f\n",answer);break;
        case 3:Cone(&answer,r,h);printf("%.2f\n",answer);break;
        default:break;
        }
    }
    return 0;
}

好的,以下是圆形体积计算器的设计方案: 首先,我们需要定义三个函数来计算、圆柱、圆锥体积。函数的参数为三个形状的相关参数。 接着,我们需要定义一个主函数来接收用户的输入,根据用户的选择调用对应的函数进行体积计算,并将计算结果打印输出。主函数需要实现以下功能: 1. 通过命令方式输入1、2、3,别选择计算、圆柱、圆锥体积。 2. 根据用户的选择,接收计算所需的相应参数,并传递给对应的函数进行计算。 3. 打印输出计算结果。 下面是实现该程序的 Python 代码: ``` import math def calc_sphere_volume(radius): volume = 4/3 * math.pi * radius**3 return volume def calc_cylinder_volume(radius, height): volume = math.pi * radius**2 * height return volume def calc_cone_volume(radius, height): volume = 1/3 * math.pi * radius**2 * height return volume def main(): shape = input("请选择要计算圆形的形状(1-球,2-圆柱,3-圆锥):") if shape == "1": radius = float(input("请输入球半径:")) volume = calc_sphere_volume(radius) print(f"球体积为:{volume}") elif shape == "2": radius = float(input("请输入圆柱底面半径:")) height = float(input("请输入圆柱高:")) volume = calc_cylinder_volume(radius, height) print(f"圆柱体积为:{volume}") elif shape == "3": radius = float(input("请输入圆锥底面半径:")) height = float(input("请输入圆锥高:")) volume = calc_cone_volume(radius, height) print(f"圆锥体积为:{volume}") else: print("非法的输入!") if __name__ == "__main__": main() ``` 使用示例: ``` 请选择要计算圆形的形状(1-球,2-圆柱,3-圆锥):1 请输入球半径:3 球体积为:113.09733552923254 ``` ``` 请选择要计算圆形的形状(1-球,2-圆柱,3-圆锥):2 请输入圆柱底面半径:2 请输入圆柱高:4 圆柱体积为:50.26548245743669 ``` ``` 请选择要计算圆形的形状(1-球,2-圆柱,3-圆锥):3 请输入圆锥底面半径:2 请输入圆锥高:4 圆锥体积为:16.755160819145567 ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值