HDU 1160 FatMouse's Speed

32 篇文章 0 订阅

HDU 1160 FatMouse's Speed  

2010-10-12 21:06:40|  分类: 动态规划|字号 订阅

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2702    Accepted Submission(s): 1138

Special Judge
Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 
Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.
The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.
Two mice may have the same weight, the same speed, or even the same weight and speed. 
 
Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 
W[m[1]] < W[m[2]] < ... < W[m[n]]
and 
S[m[1]] > S[m[2]] > ... > S[m[n]]
In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
 
Sample Input


6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900


 
Sample Output


4 4 5 9 7


 
Source
Zhejiang University Training Contest 2001 
 
Recommend
Ignatius

//DP算法:  
设Mice[i].W表示第i只老鼠的重量,Mice[i].S表示第i只老鼠的速度。我们先对Mice进行排序,以W为第一关键字,从小到大,S为第二关键字,从大到小。  
设f[i]为Mice[i]至Mice[n]最长的序列长度。考虑某一个f[i],则有: 
  
nf[i] = max(f[i], f[j]+1) (1<=j<i,且Mice[i].W> Mice[j].W,Mice[i].S < Mice[j].S) 
n其中,初始条件为f[i]=1 (i=1, 2, ..., n)。 
//程序如下:

#include<iostream>
#include<algorithm>
using namespace std;

struct mouse                   //定义一个mouse结构体
{
     int W,S;
     int NO;
};

mouse m[10000];           //声明一个mouse类型数组
int f[10000];                    //f[]用来存到第i只老鼠时,前面最大的老鼠的数量 
int g[10000];                   //g[]用来存第i只老鼠前面的一只老鼠的序号

bool cmp(mouse a,mouse b)           //编译器里面的sort()内置函数,定义自己的的排序函数
{
       if(a.W==b.W) return a.S>b.S;  //如果两只mouse的体重相等,就速度快的排在前面
       else return a.W<b.W;              //两只mouse体重小的排在前面
}

int main()
{
      int i=0,j,n,max=0,flag=0;
      while(scanf("%d%d",&m[i].W,&m[i].S)!=EOF)      .//输入mouse的体重,速度和编号
     {
           m[i].NO=i+1;                                         
           i++;

     }
     n=i;
     sort(m,m+n,cmp);                                                //进行排序

     f[0]=1;g[0]=0;max=1;                                           //数据初始化
     for(i=1;i<n;i++) 
     {
          f[i]=1;
          for(j=i-1;j>=0;j--)
         {
              if(m[i].W>m[j].W&&m[i].S<m[j].S&&f[j]+1>f[i])     //体重要上升,速度要下降,数量要增加

              {                                                                    
                  f[i]=1+f[j];
                  g[i]=j;
              }
         }
         if(max<f[i])              //每次最大的一次数量,并记录后到数量最大的那只老鼠的排序号
         {
              max=f[i];
              flag=i;
          }
      }
 
      for(i=0,j=max-1;i<max;i++)   //将排序号倒置过来
      {
            f[j--]=flag;
            flag=g[flag];
       }

       printf("%d\n",max);
       for(i=0;i<max;i++)
          printf("%d\n",m[f[i]].NO);    //输出老鼠的编号

       return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值