【洛谷P1897】 [USACO06NOV]玉米田Corn Fields-状压dp

题目描述

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

农场主John新买了一块长方形的新牧场,这块牧场被划分成M行N列(1 ≤ M ≤ 12; 1 ≤ N ≤ 12),每一格都是一块正方形的土地。John打算在牧场上的某几格里种上美味的草,供他的奶牛们享用。

遗憾的是,有些土地相当贫瘠,不能用来种草。并且,奶牛们喜欢独占一块草地的感觉,于是John不会选择两块相邻的土地,也就是说,没有哪两块草地有公共边。

John想知道,如果不考虑草地的总块数,那么,一共有多少种种植方案可供他选择?(当然,把新牧场完全荒废也是一种方案)

输入输出格式

输入格式:

 

第一行:两个整数M和N,用空格隔开。

第2到第M+1行:每行包含N个用空格隔开的整数,描述了每块土地的状态。第i+1行描述了第i行的土地,所有整数均为0或1,是1的话,表示这块土地足够肥沃,0则表示这块土地不适合种草。

 

输出格式:

 

一个整数,即牧场分配总方案数除以100,000,000的余数。

 

输入输出样例

输入样例#1: 

2 3
1 1 1
0 1 0

输出样例#1: 

9

思路:

状压dp,可以将一排的n个数0 1 看成二进制数,然后预处理每一行可以存在的状态,比如101 100 001 010这几个,

然后dp,枚举当前有效状态与上一行有效状态是否能够同时存在,可以就加起来就行了,

假设f[i][j]表示前i行中第i行为j这个可行状态时候的方案数

状态转移方程:

          for(int k=1;k<=a[i-1].num;k++)
            {
                if(a[i].st[j]&a[i-1].st[k]) continue;

                f[i][j]+=f[i-1][k];
            }(这个是全部情况加起来,不知道怎么表达,直接从代码上弄出来的。。。)

初始条件: f[1][i]=1(1<=i<=a[1].num).

目标:最终那一行的可行状态f[m][j]的加和;

 

代码:

#include<iostream>
using namespace std;

const int maxn=15;
struct state
{
    int st[4396],num;
}a[maxn];

int m,n,f[maxn][1000]={0};

void getstate(int i,int t)
{
    int num=0;
    for(int j=0;j<(1<<n);j++)
    {
        if((j&(j<<1))||(j&(j>>1))||(j&t))
            continue;
        else
            a[i].st[++num]=j;
    }
    a[i].num=num;
}

void Init()
{
    int t,x;
    cin>>m>>n;
    for(int i=1;i<=m;i++)
    {
        t=0;
        for(int j=1;j<=n;j++)
        {
            cin>>x;
            t=(t<<1)+1-x; //用十进制数t储存
        }
        getstate(i,t);//计算可行的状态
    }
}

void dp()
{
    int ans=0;

    for(int i=1;i<=a[1].num;i++)
        f[1][i]=1;

    for(int i=2;i<=m;i++)
    {
        for(int j=1;j<=a[i].num;j++)
        {
            f[i][j]=0;
            for(int k=1;k<=a[i-1].num;k++)
            {
                if(a[i].st[j]&a[i-1].st[k]) continue; //上下两行的可行状态不相容
                                       
                f[i][j]+=f[i-1][k];
            }
        }
    }
    for(int i=1;i<=a[m].num;i++)
    {
        ans=(ans+f[m][i])%100000000;
    }
    cout<<ans<<endl;
}

int main()
{
    Init();
    dp();
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值