【POJ】3259Wormholes(Bellman_Ford判断负环是否存在)

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 67378 Accepted: 25135

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

题目大意:现在给你一个有着N各节点和W条虫洞和M条边的图,其中我们规定其中的M条边的权值是正的,而且是双向的,其中W条边权值是负的(自己加负号。。。。),而且是单向边,问你能不能回到过去的时间,也就是有没有负环,有负环就能回到过去没有就回不去,

思路:这个题目基本就是Bellmanford的模板题目,数据加载后,可以一个点一个点的判断也是能过得,但是时间比较长,我们可以用加入一个超级点的思路,

所谓超级点,比如是第0个点,也就是说他到所有点的距离都是0,设置边的时候我们可以最后设置上,但是要注意,与0节点有关的边,只能是从0到其他节点的单向边,不然没什么意义吧。

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<vector>
#define maxn 3500
#define inf 0x3f3f3f3f3f
using namespace std;

struct Edge
{
    int from,to,dist;
    Edge(int f,int t,int d):from(f),to(t),dist(d){}
};

struct Bellmanford
{
    int n,m;
    vector<int> G[maxn];
    vector<Edge> edges;
    bool inq[maxn];//判断是否在队列中
    int p[maxn];//到某节点最短路的前置节点编号
    int d[maxn]; //单源最短路
    int cnt[maxn]; //判断加入队列的次数

    void init(int n)
    {
        this->n=n;
        for(int i=0;i<n;i++)
            G[i].clear();
        edges.clear();
    }

    void AddEdge(int from,int to,int dist)
    {
        edges.push_back(Edge(from,to,dist));
        m=edges.size();
        G[from].push_back(m-1);
    }


    bool negativeCycle()
    {
        queue<int >Q;
        memset(inq,0,sizeof(inq));
        memset(cnt,0,sizeof(cnt));
        for(int i=0;i<n;i++)
            d[i]= i==0?0:inf;
        Q.push(0); //从超级点开始就好

        while(!Q.empty())
        {
            int u=Q.front();Q.pop();
            inq[u]=false;
            for(int i=0;i<G[u].size();i++)
            {
                Edge &e=edges[G[u][i]];

                if(d[e.to]>d[u]+e.dist)
                {
                    d[e.to]=d[u]+e.dist;
                    p[e.to]=G[u][i];
                    if(!inq[e.to])
                    {
                        Q.push(e.to);
                        inq[e.to]=true;
                        if(++cnt[e.to]>n) return true;
                    }
                }
            }
        }
        return false;
    }
}BF;

int main()
{
    int t;cin>>t;
    while(t--)
    {
        int n,m,w;
        cin>>n>>m>>w;
        BF.init(n+1);
        int s,e,t;
        while(m--)
        {
            cin>>s>>e>>t;
            BF.AddEdge(s,e,t);
            BF.AddEdge(e,s,t);
        }
        while(w--)
        {
            cin>>s>>e>>t;
            BF.AddEdge(s,e,-t);
        }
        for(int i=1;i<=n;i++) //加入超级点0点
            BF.AddEdge(0,i,0);
        if(BF.negativeCycle())//最后有负环说明是可以回到过去的
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值