【HDU】5501The Highest Mark(排序+01背包)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1323    Accepted Submission(s): 565


 

Problem Description

The SDOI in 2045 is far from what it was been 30 years ago. Each competition has t minutes and n problems.

The ith problem with the original mark of Ai(Ai≤106) ,and it decreases Bi by each minute. It is guaranteed that it does not go to minus when the competition ends. For example someone solves the ith problem after x minutes of the competition beginning. He/She will get Ai−Bi∗x marks.

If someone solves a problem on x minute. He/She will begin to solve the next problem on x+1 minute.

dxy who attend this competition with excellent strength, can measure the time of solving each problem exactly.He will spend Ci(Ci≤t) minutes to solve the ith problem. It is because he is so godlike that he can solve every problem of this competition. But to the limitation of time, it's probable he cannot solve every problem in this competition. He wanted to arrange the order of solving problems to get the highest mark in this competition.

 

 

Input

There is an positive integer T(T≤10) in the first line for the number of testcases.(the number of testcases with n>200 is no more than 5 )

For each testcase, there are two integers in the first line n(1≤n≤1000) and t(1≤t≤3000) for the number of problems and the time limitation of this competition.

There are n lines followed and three positive integers each line Ai,Bi,Ci . For the original mark,the mark decreasing per minute and the time dxy of solving this problem will spend.


Hint:
First to solve problem 2 and then solve problem 1 he will get 88 marks. Higher than any other order.

 

 

Output

For each testcase output a line for an integer, for the highest mark dxy will get in this competition.

 

 

Sample Input

 

1 4 10 110 5 9 30 2 1 80 4 8 50 3 2

 

 

Sample Output

 

88

 

 

Source

BestCoder Round #59 (div.1)

 

 

Recommend

hujie

 

题目大意:类似于比赛的赛制,看其中的得分,给你N道题,M个时间,花费时间做题的同时还要接受花费时间多少给出的减分,做一道题得A分,这一道题一个时间减少B分,做出来这个题需要C个时间。

思路:

现在有A1,B1,C1和A2,B2,C2这两道题,如果先做1再做2的得分是A1-B1*C1+A2-B2*(C1+C2),如果先做2在做1的得分是A2-B2*C2+A1-B1*(C1+C2),令先做1再做2的得分更高些,那么有A1-B1*C1+A2-B2*(C1+C2) >= A2-B2*C2+A1-B1*(C1+C2),解得B1*C2>=B2*C1

 代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define maxn 3500
using namespace std;
int dp[maxn];
int n,m;
struct Data
{
    int a,b,c;
    Data() {}
    Data(int d,int e,int f):a(d),b(e),c(f){}
    bool operator <(const Data &ags) const
    {
        return b*ags.c>ags.b*c;
    }
}D[maxn];

int main()
{
    int t;cin>>t;
    while(t--)
    {
        cin>>n>>m;
        for(int i=1;i<=n;i++)
        {
            cin>>D[i].a>>D[i].b>>D[i].c;
        }
        sort(D+1,D+n+1);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            for(int j=m;j>=D[i].c;j--)
                dp[j]=max(dp[j],dp[j-D[i].c]+D[i].a-D[i].b*j);
        int ans=0;
        for(int j=0;j<=m;j++)
            ans=max(ans,dp[j]);
        cout<<ans<<endl;
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值