U - Long Distance Racing

Bessie is training for her next race by running on a path that includes hills so that she will be prepared for any terrain. She has planned a straight path and wants to run as far as she can -- but she must be back to the farm within M seconds (1 ≤ M ≤ 10,000,000).

The entire path she has chosen is T units (1 ≤ T ≤ 100,000) in length and consists of equal-length portions that are uphill, flat, or downhill. The input data describes path segment i with a single character Si that is u, f, or d, indicating respectively uphill, flat, or downhill.

Bessie takes U seconds (1 ≤ U ≤ 100) to run one unit of uphill path, F (1 ≤ F ≤ 100) seconds for a unit of flat path, and D (1 ≤ D ≤ 100) seconds for a unit of downhill path. Note that, when returning home, uphill paths become downhill paths and downhill paths become uphill paths.

Find the farthest distance Bessie can get from the farm and still make it back in time.

Input

* Line 1: Five space-separated integers: M, T, U, F, and D
* Lines 2..T+1: Line i+1 describes path segment i with a single letter: Si

Output

* Line 1: A single integer that is the farthest distance (number of units) that Bessie can get from the farm and make it back in time.

Sample Input
13 5 3 2 1
u
f
u
d
f
Sample Output
3
题意:Bessie 练习跑步,但他必须在一定的时间内回去。输入M,T,U,F,D,M表示总时间,T表示T个不同的路况,路况:u上坡,f平坦,d下坡,UFD表示不同路况所需要的时间,输入最远能走多少段路,从第一段开始,把每一段路来回所需要的时间加起来,当大于总时间时输出。因为有回程,所以,,
#include<iostream>
#include<cstdio>
using namespace std;
char a[100000]; 
int main()
{
 int i,sum=0,step=0;
 int m,t,u,f,d;
 cin>>m>>t>>u>>f>>d;
 for(i=0;i<t;i++)
 {
  cin>>a[i];
 }
 for(i=0;i<t;i++)
 {
  if(a[i]=='u'||a[i]=='d')//上下坡一样,来回所需时间一样 
  {
   sum+=(u+d); 
  }
  else
  {
   sum+=2*f;
  }
  if(sum>m)//大于退出,否则加一 
  {
   break;
  }
  else
  {
   step+=1;
  }
  
 }
 cout<<step<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值