迷宫问题 POJ - 3984

Description

定义一个二维数组: 

int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
#include <cstdio>
#include <cstring>
#include<queue>
#include<iostream>
using namespace std;

int map[10][10]; //地图
int vis[10][10]; //判重
int dir[4][2] = {{-1,0},{1,0},{0,-1},{0,1}};

typedef struct {
	int x,y; //坐标

	int x1,y1;
}node;

queue<node> q;

node where[10][10];

void print(node head)
{

	while( head.x1 != -1  && head.y1 != -1 )
	{
		print(where[head.x1][head.y1]);
		printf("(%d, %d)\n",head.x, head.y);

		return;
	}
	printf("(0, 0)\n");
}



void bfs(int x,int y)
{
    node one;
    one.x1=one.y1=-1;
    one.x=x;
    one.y=y;
    vis[x][y] = 1;
    //where[x][y].x1=where[x][y].y1=-1;
    //where[x][y].x=x;
    //where[x][y].y=y;
    where[x][y]=one;
    //cout<<where[0][0].x1<<" "<<where[0][0].y1<<endl;
	q.push(one);
	while( !q.empty() )
	{
	    node zhong;
	    zhong=q.front();
	    q.pop();

		if(zhong.x == 4 && zhong.y == 4)
		{
		    //cout<<zhong.x1<<" "<<zhong.y1<<endl;


			print(zhong);
			return;
		}
		for(int i = 0;i < 4;i++)
		{
		    node now;
			now.x = zhong.x + dir[i][0];
			now.y = zhong.y + dir[i][1];
			now.x1 = zhong.x;
			now.y1 = zhong.y;

			if(now.x >= 0 && now.x <= 4 && now.y >= 0 && now.y <= 4)
			{
				if(!vis[now.x][now.y] && !map[now.x][now.y])
				{
				    //cout<<now.x<<" "<<now.y<<endl;
					vis[now.x][now.y] = 1;
					where[now.x][now.y]=now;
					q.push(now);
					//cout<<where[0][0].x1<<" "<<where[0][0].y1<<endl;
					//cout<<where[1][0].x1<<" "<<where[1][0].y1<<endl;
					//tail++;
				}
			}
		}
		//head++;
	}
}

int main()
{
	int i,j;
	for(i = 0;i < 5;i++)
	{
		for(j = 0;j < 5;j++)
		{
			scanf("%d",&map[i][j]);
		}
	}
	memset(vis,0,sizeof(vis));
	bfs(0,0);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值