hdu oj Period (kmp的应用)

11 篇文章 0 订阅
10 篇文章 0 订阅

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2866    Accepted Submission(s): 1433


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
  
  
3 aaa 12 aabaabaabaab 0
 

Sample Output
  
  
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
                                                     

这道题开始看了好久都没懂题意,后来对着样例看了一下,把题意大体弄懂了,就是给你一个字符串,求里面的循环节的个数,从第二个字符开始,判断是否是循环串,并求出循环的周期(出现的次数);然后我自己想开始想到字符串匹配;还觉得要用二个字符串,感觉kmp还是没理解到位;又把kmp看了一下,看大神的思路,其实这就是对next数组的一种应用;next数组其实保存的就是字符串的相似度;保存的是其前一个字符的前缀和后缀相等的最大值,假如next[i]的值为6,那么它的前一个字符前缀和后缀最多就有6个相等;
字符的编号从0开始,这里面就可以推出一个规律;那么if(i%(i-next[i])==0),则i前面的串为一个轮回串,其中轮回子串出现i/(i-next[i])次。
下面是ac的代码;
#include <cstdio>
#include <cstring>
int n;
int next[1000001];
char s[1000001];
void get_next()//求出next数组
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<=n)
    {
        if(j==-1 || s[i]==s[j])
        {
            ++i;
            ++j;
            next[i]=j;
        }
        else
        j=next[j];
    }
}
int main()
{
    int t,j=1;
    while(scanf("%d",&n)&&n)
    {
       scanf("%s",s);
       get_next();
       printf("Test case #%d\n",j++);
       for(int i=2;i<=n;i++)
       {
           t=i-next[i]; //关键点在这里
           if(i%t==0&&i/t>1)
           {
               printf("%d %d\n",i,i/t);
           }
       }
       printf("\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值