【思维 | 翻转问题】POJ 3279 Fliptile

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source

USACO 2007 Open Silver


枚举第一行的状态,然后根据依次遍历n*m,当前行是否翻转取决于它的上一行的状态,最后检查最后一行是否全是0即可。

(同一个格子翻转两次是无用的,并且翻转次序也无用)


/*
	狗贼,看我代码请自动转账一元 
*/ 
//#include<bits/stdc++.h>
#include <iostream>
#include <stdlib.h>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <iomanip>
//#pragma GCC optimize(2)
#include<time.h>
#include <map>
#include <queue>
#include <stack>
#include <cmath>
#include <algorithm>
using namespace std;
#define maxn 25
#define inf 1e18
#define eps 0.00001
typedef long long ll;
const ll mod = 1e9+7;
const double pi = acos(-1);

ll n,m,arr[maxn][maxn],ans[maxn][maxn],temp[maxn][maxn],flag = -1;

void change(ll x)
{
	
	for(ll i = m; i >= 1; i--)
	{
		temp[1][i] = x%2;
		x = x/2;
	}
	
	return ;
}

void update()
{
	
	ll num1 = 0,num2 = 0;
	for(ll i = 1; i <= n; i++)
	{
		for(ll j = 1; j <= m; j++)
		{
			if(ans[i][j] == 1)
				num1++;
			if(temp[i][j] == 1)
				num2++;
		}
	}
	
	if(num2 < num1)
	{
		for(ll i = 1; i <= n; i++)
			for(ll j = 1; j <= m; j++)
				ans[i][j] = temp[i][j];
		
	}
	
	return ;
}

bool c(ll x,ll y)
{
	ll numm = 0;
	if( temp[x][y] == 1 )
		numm++;
	if( temp[x][y-1] == 1 )
		numm++;
	if( temp[x][y+1] == 1 )
		numm++;
	if( temp[x-1][y] == 1 )
		numm++;
	if( temp[x+1][y] == 1 )
		numm++;
	
	if(numm%2 == 1)
		return 1;
	else
		return 0;
	
}

bool check()
{
	for(ll i = 1; i <= m; i++)
	{
		if ( (arr[n][i] == 0 && c(n,i) ) == 1 || (arr[n][i] == 1 && c(n,i) == 0 ) )
			return false;
	}
	
	return true;
}

void slove()
{
	for(ll t = 0; t < (1 << m); t++)
	{
		memset(temp,0,sizeof(temp));
		change(t);
		for(ll i = 2; i <= n; i++)
		{
			for(ll j = 1; j <= m; j++)
			{
				if( (arr[i-1][j] == 1 && c(i-1,j) == 0 ) || (arr[i-1][j] == 0 && c(i-1,j) == 1 ) )
				{
					temp[i][j] = 1; 
				}	
			} 	
		}
		
		if( check() )
		{
			flag = 1;
			update();
		}
				
	}
	
	
	if(flag == -1)
	{
		cout << "IMPOSSIBLE" << endl;
	}
	else
	{
		for(ll i = 1; i <= n; i++)
		{
			for(ll j = 1; j <= m; j++)
			{
				cout << ans[i][j] << " ";
			}
			cout << endl;
		}
	}
	
	return ;
}

int main()
{
    //srand((ll)time(0));

	cin >> n >> m;
	
	for(ll i = 1; i <= n; i++)
		for(ll j = 1; j <= m; j++)
			cin >> arr[i][j];
		
	
	for(ll i = 1; i <= n; i++)
		for(ll j = 1; j <= m; j++)
			ans[i][j] = 1;
	
	slove();
		
    return 0;
}
//fabs(t1-t2) >= eps

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值