《阿里巴巴Java开发手册》插件安装及使用

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/whzhaochao/article/details/78247260

Idea安装

IDEA版的插件已发布到IDEA官方仓库中(最低支持版本14.1.7,JDK1.7+),只需打开 Settings >> Plugins >> Browse repositories 输入 Alibaba 搜索一下便可以看到对应插件了,点击安装等待安装完成。至于如何使用请大家到官方Github仓库中进行查看。IDEA会自动检测插件新版,并提示出来,所以大家不用担心插件的更新问题。

eclipse安装

Eclipse版插件支持4.2(Juno,JDK1.8+)及以上版本,我们提供自主的Update Site,通过 Help >> Install New Software 然后输入https://p3c.alibaba.com/plugin/eclipse/update 即可看到安装列表。大家可以通过 Help >> Check for Udates 进行插件新版检测。

基本使用

项目扫描

在项目右击选择”编码规约扫描”
这里写图片描述
查看扫描结果如下图所示:
这里写图片描述

这里写图片描述

扫描结果分为三类,选择不符合规范的代码可查看到相应的修改建议。
- Blocker
- Critical
- Major

参数文章

https://yq.aliyun.com/articles/224345?spm=5176.100238.spm-cont-list.5.MCBO1v

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页