Max Sum

33 篇文章 0 订阅
4 篇文章 0 订阅

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 178412
Accepted Submission(s): 41634

Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

最初想到的是用两层for循环求出它的所有子列的和,输出最大的,却总是超时,看了别人的代码后继续研究,提交八次的题,注意

#include<stdio.h>
#define max 100000
int main()
{
    int sum,maxx,t,n,x,z,y,a[max];
    scanf("%d",&t);
    for(int k=1;k<=t;k++)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
        sum=0;maxx=-1111;
        x=z=y=1;
        for(int j=1;j<=n;j++)
        {
            sum+=a[j];
            if(sum>maxx)//两个if的位置绝对不能调换
            {
                x=z;
                y=j;
                maxx=sum;
            }
            if(sum<0)//放在上面后,若先输入负数就会出错
            {
                z=i+1;
                sum=0;
            }
        }
        printf("Case %d:\n",k);
        printf("%d %d %d\n",maxx,x,y);
        if(k!=t)//最后一个不能有两次换行,会出现Presentation Error
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值