找爸爸游戏

Relative Relatives

My Tags1   (Edit)
  Source : ACM ICPC South Central USA 2004
  Time limit : 1 sec   Memory limit : 32 M

Submitted : 66, Accepted : 50

Today is Ted's 100th birthday. A few weeks ago, you were selected by the family to contact all of Ted's descendants and organize a surprise party. To make this task easier, you created an age-prioritized list of everyone descended from Ted. Descendants of the same age are listed in dictionary order.

The only materials you had to aid you were birth certificates. Oddly enough, these birth certificates were not dated. They simply listed the father's name, the child's name, and the father's exact age when the baby was born.

Input

Input to this problem will begin with line containing a single integer n indicating the number of data sets. Each data set will be formatted according to the following description.

A single data set has 2 components:

  1. Descendant Count - A line containing a single integer X (where 0 < X < 100) indicating the number of Ted's descendants.
  2. Birth Certificate List - Data for X birth certificates, with one certificate's data per line. Each certificate's data will be of the format "FNAME CNAME FAGE where:
    • FNAME is the father's name.
    • CNAME is the child's name.
    • FAGE is the integer age of the father on the date of CNAMEs birth.

Note:

  • Names are unique identifiers of individuals and contain no embedded white space.
  • All of Ted's descendants share Ted's birthday. Therefore, the age difference between any two is an integer number of years. (For those of you that are really picky, assume they were all born at the exact same hour, minute, second, etc... of their birth year.)
  • You have a birth certificate for all of Ted's descendants (a complete collection).

Output

For each data set, there will be X+1 lines of output. The first will read, "DATASET Y, where Y is 1 for the first data set, 2 for the second, etc. The subsequent X lines constitute your age-prioritized list of Ted's descendants along with their ages using the format "NAME AGE. Descendants of the same age will be listed in dictionary order.

Sample Input

2
1
Ted Bill 25
4
Ray James 40
James Beelzebub 17
Ray Mark 75
Ted Ray 20
Sample Output
DATASET 1
Bill 75
DATASET 2
Ray 80
James 40
Beelzebub 23
Mark 5

//找爸爸游戏
#include <iostream>
#include <string>
using namespace std;

struct _DataC{
	string father;  
	string son;
	int year;
}Association[100][100];

struct _Son{
	string name;
	int age;    //所有儿子的年龄默认为0
	int fatherPoint;
}Son[100][100];

int Min(int x,int y){
	int min;
	if(x>y)
		min=y;
	else
		min=x;
	return min;
}

int CompareStr(string strA,string strB){
	//按照字典顺序排序,如果A在前面返回1,A在后面返回0。
	int result=-1;
	int SizeA,SizeB;
	char a,b;
	int N;
	SizeA=strA.size();
	SizeB=strB.size();
	N=min(SizeA,SizeB);
	int i=0;
	while(i<N){
		a=strA[i];
		b=strB[i];
		if(a>b){
			result=0;
			break;
		}else if(a<b){
			result=1;
			break;
		}else{
			
		}
		i++;
	}
	if(result==-1){
		if(SizeA>SizeB)
			result=0;
		else
			result=1;
		//不考虑SizeA==SizeB的极小概率事件
	}
	return result;
}

int main(){
	int N;//数据组数
	int i,j,k,l;
	int num[100];
	int a[100];
	int sign,sign1;
	int pos,pos1;
	struct _Son tempSon;

	cin>>N;
	for(i=0;i<N;i++){
		cin>>a[i];
		for(j=0;j<a[i];j++){
			cin>>Association[i][j].father>>Association[i][j].son>>Association[i][j].year;
		}
	}
	//赋名字
	for(i=0;i<N;i++){
		Son[i][0].name="Ted";
		Son[i][0].age=100;
		Son[i][0].fatherPoint=-1;
		num[i]=1;
		for(j=0;j<a[i];j++){
			sign=1;
			for(l=0;l<num[i];l++){
				if(Association[i][j].father==Son[i][l].name){
					pos=l;
					sign=0;
				}
			}
			if(sign){
				Son[i][num[i]].name=Association[i][j].father;
				pos=num[i];
				num[i]++;
			}
			sign1=1;
			for(l=0;l<num[i];l++){
				if(Association[i][j].son==Son[i][l].name){
					pos1=l;
					sign1=0;
				}
			}
			if(sign1){
				Son[i][num[i]].name=Association[i][j].son;
				pos1=num[i];
				num[i]++;
			}
			Son[i][pos1].fatherPoint=pos;
			Son[i][pos1].age=0-Association[i][j].year;
		}
	}
	for(i=0;i<N;i++){
		for(j=0;j<num[i];j++){
			for(k=j+1;k<num[i];k++){
				if(Son[i][j].fatherPoint>Son[i][k].fatherPoint){
					tempSon=Son[i][k];
					Son[i][k]=Son[i][j];
					Son[i][j]=tempSon;
				}
			}
		}
	}
	//计算年龄
	for(i=0;i<N;i++){
		for(j=1;j<num[i];j++){
			Son[i][j].age=Son[i][j].age+Son[i][Son[i][j].fatherPoint].age;
		}
	}
	for(i=0;i<N;i++){
		for(j=0;j<num[i];j++){
			for(k=j+1;k<num[i];k++){
				if(Son[i][k].age>Son[i][j].age||(Son[i][k].age==Son[i][j].age&&CompareStr(Son[i][k].name,Son[i][j].name))){
					tempSon=Son[i][j];
					Son[i][j]=Son[i][k];
					Son[i][k]=tempSon;
				}
			}
		}
	}
	for(i=0;i<N;i++){
		cout<<"DATASET "<<i+1<<endl;
		for(j=1;j<num[i];j++){
			cout<<Son[i][j].name<<" "<<Son[i][j].age<<endl;
		}
	}
	//system("pause");
	return 0;
}

运行结果正确,但是不能ac,可能是某些辩解条件没有考虑,我还在找bug,等找到再做修改


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值