尼姆博弈 Match Games

Description

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output

No
<p>Yes</p><p>
</p><p>
</p><p></p><p>尼姆博弈:</p><p>目前有任意堆石子,每堆石子个数也是任意的,双方轮流从中取出石子,规则如下:</p><p>1<span style="font-family:宋体;">〉每一步应取走至少一枚石子;每一步只能从某一堆中取走部分或全部石子;</span></p><p>2<span style="font-family:宋体;">〉如果谁取到最后一枚石子就胜</span></p><p>45 45</p><p>3 6 9</p><p>将各堆石子进行异或,<span style="font-family:Courier New;">45^45,3^6^9(c++</span><span style="font-family:宋体;">中异或符号为</span><span style="font-family:Courier New;">^</span><span style="font-family:宋体;">可以直接使用</span><span style="font-family:Courier New;">)</span><span style="font-family:宋体;">,</span></p><p>If<span style="font-family:宋体;">异或后结果为</span><span style="font-family:Courier New;">0</span><span style="font-family:宋体;">,则输;为</span><span style="font-family:Courier New;">1</span><span style="font-family:宋体;">,否则赢</span></p><p><pre name="code" class="cpp">#include<iostream>
using namespace std;
int main()
{
       int N;
       int i;
   long int a[23];
       int sum;
       while(cin>>N)
       {
              for(i=0; i<N; i++)
                     cin>>a[i];
           sum=a[0];
              for(i=1; i<N; i++)
                     sum=sum^a[i];
              if(sum==0)
                     cout<<"No"<<endl;
              else
                     cout<<"Yes"<<endl;
       }
       return 0;
}




                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值