hdu4295 4 substrings problem 状压dp

4 substrings problem

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 583    Accepted Submission(s): 180


Problem Description
  One day you heard the following joke 
     In America, you write strings.
    In Soviet Russia, String writes YOU!!
  1
  And find that now string is writting you! So to get rid of it, you must solve the following problem:
  Given a string S and its four substring a,b,c, and d. In a configuration, you can place four substrings exactly one position it occurs in S (they may overlap), and characters covered by at least one such substring is called “covered”.
  You should solve for minimum and maximum possible number of covered characters in a configuration.
  You may assume that s contains only lowercase letters, and is of length less than 4096. However, lengths of a,b,c, and d would never exceed 64.
-------------------------------------------------------------------
1An infamous Russian reversal
 

Input
  There are several test cases.
  For each test case there are 5 lines, denoting S,a,b,c, and d, respectively.
  Please process until the EOF (End Of File).
 

Output
  For each test case, please print a single line with two integers, first the minimum, then the maximum.
 

Sample Input
  
  
hello he l l o abacaba ab ba a c
 

Sample Output
  
  
4 5 4 6
 

Source
 

Recommend
liuyiding
 

状压大法好

先暴力处理每个字串在原串中的位置。。

用dp[i][j][k]表示主串选到第i位了,a,b,c,d四个字串有没有选过(2^4),从这一位开始后面已经放定的长度为k,表示的最大值或最小值

然后用队列维护一下即可。。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define max(a,b) (a>=b ? a:b)
#define min(a,b) (a<=b ? a:b)
#define inf 0x3f3f3f3f
using namespace std;
char s[4100],ss[4][66];
bool check[4][4100];
int len[4];
void read(){
    for(int i=0;i<4;i++) scanf("%s",ss[i]+1);
}
int dp[4100][16][66];
struct node{
    int x,st,l;
    node(int x,int st,int l):x(x),st(st),l(l){}
};
int bfs(){
    queue<node> q;
    q.push(node(0,0,0));
    memset(dp,-1,sizeof dp);
    dp[0][0][0]=0;
    int l=strlen(s+1);
    while(!q.empty()){
        node v=q.front();
        q.pop();
        if(v.x==l+1) continue;
        for(int i=0;i<4;i++){
            if(v.st&(1<<i)) continue;
            int ll;
            if(check[i][v.x]){
                ll=max(v.l,len[i]);
                if(dp[v.x][v.st|(1<<i)][ll]==-1){
                    q.push(node(v.x,v.st|(1<<i),ll));
                }
                dp[v.x][v.st|(1<<i)][ll]=max(dp[v.x][v.st|(1<<i)][ll],dp[v.x][v.st][v.l]);
            }
        }
        int ll=max(v.l-1,0);
        if(dp[v.x+1][v.st][ll]==-1){
            q.push(node(v.x+1,v.st,ll));
        }
        dp[v.x+1][v.st][ll]=max(dp[v.x+1][v.st][ll],dp[v.x][v.st][v.l]+(v.l ? 1:0));
    }
    int ret=-1;
    for(int i=1;i<=l;i++){
        ret=max(ret,dp[i][15][1]+1);
    }
    if(ret==-1) return 0;
    else return ret;
}
int bfs1(){
    queue<node> q;
    q.push(node(0,0,0));
    memset(dp,0x3f,sizeof dp);
    dp[0][0][0]=0;
    int l=strlen(s+1);
    while(!q.empty()){
        node v=q.front();
        q.pop();
        //cout<<v.x<<" "<<v.st<<" "<<v.l<<" "<<dp[v.x][v.st][v.l]<<endl;
        if(v.x==l+1) continue;
        for(int i=0;i<4;i++){
            if(v.st&(1<<i)) continue;
            int ll;
            if(check[i][v.x]){
                ll=max(v.l,len[i]);
                if(dp[v.x][v.st|(1<<i)][ll]==inf){
                    q.push(node(v.x,v.st|(1<<i),ll));
                }
                dp[v.x][v.st|(1<<i)][ll]=min(dp[v.x][v.st|(1<<i)][ll],dp[v.x][v.st][v.l]);
            }
        }
        int ll=max(v.l-1,0);
        if(dp[v.x+1][v.st][ll]==inf){
            q.push(node(v.x+1,v.st,ll));
        }
        dp[v.x+1][v.st][ll]=min(dp[v.x+1][v.st][ll],dp[v.x][v.st][v.l]+(v.l ? 1:0));
    }
    int ret=inf;
    for(int i=1;i<=l;i++){
        ret=min(ret,dp[i][15][1]+1);
    }
    if(ret==inf) return 0;
    else return ret;
}
void solve(){
    memset(check,0,sizeof check);
    int l=strlen(s+1);
    for(int i=0;i<4;i++){
        len[i]=strlen(ss[i]+1);
        for(int j=1;j<=l;j++){
            if(s[j]==ss[i][1]){
                int k=1,tmp=j,jj=j;
                while(k<=len[i]&&s[jj]==ss[i][k]) jj++,k++;
                if(k==len[i]+1) {
                    check[i][tmp]=1;
                }
            }
        }
    }
    printf("%d %d\n",bfs1(),bfs());
}
int main(){
    //freopen("input","r",stdin);
    //freopen("out2","w",stdout);
    while(~scanf("%s",s+1)){
        read();
        solve();
    }
    return 0;
}


购物商城项目采用PHP+mysql有以及html+css jq以及layer.js datatables bootstorap等插件等开发,采用了MVC模式,建立一个完善的电商系统,通过不同用户的不同需求,进行相应的调配和处理,提高对购买用户进行配置….zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值