The Coco-Cola Store(湖南省第六届ACM竞赛题)

The Coco-Cola Store
Time Limit:1000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description


� Once upon a time, there is a special coco-cola store. If you return three empty bottles to the shop, you'll get a full bottle of coco-cola to drink. If you have n empty bottles right in your hand, how many full bottles of coco-cola can you drink?

Input

There will be at most 10 test cases, each containing a single line with an integer  n (  1$ \le$n$ \le$100). The input terminates with  n = 0, which should not be processed.

Output

For each test case, print the number of full bottles of coco-cola that you can drink.

Sample Input

3
10
81
0

Sample Output

1
5
40


Spoiler

Let me tell you how to drink 5 full bottles with 10 empty bottles: get 3 full bottles with 9 empty bottles, drink them to get 3 empty bottles, and again get a full bottle from them. Now you have 2 empty bottles. Borrow another empty bottle from the shop, then get another full bottle. Drink it, and finally return this empty bottle to the shop!



Problemsetter: Rujia Liu, Special Thanks: Yiming Li & Sohel Hafiz


直接暴力

AC代码:

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int n,hg,now,i,sum;
    while(scanf("%d",&n)&&n)
    {
        sum = hg = 0;
        now = n;
        while(now>1)
        {
            hg = now/3;
            sum+=hg;
            now = now%3;
            now = now+hg;
            if(now==2)
            {
                sum++;
                now = 0;
                hg = 0;
            }
        }
        printf("%d\n",sum);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值