杭电 1006 Oil Deposits

http://acm.hdu.edu.cn/diy/contest_showproblem.php?cid=20044&pid=1006

Oil Deposits

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 17   Accepted Submission(s) : 11
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2

注意这个题又8个方向。
这个题杭电出的测试数据好坑爹!!用scanf输入时有问题的,因为他的测试数据里面输入n和m时前面两组时输入完马上回车,而在最
后两组5 5 和0 0两个数输入完了后 还有一个空格 ,然后再回车。所以改为用cin输入了。
我在这个地方被坑了一个小时。。。哭啊!!!!!!!!!
AC代码:
#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>

using namespace std;

char map[110][110];
int dir[8][2]={{0,1},{0,-1},{1,0},{-1,0},{1,1},{-1,-1},{1,-1},{-1,1}};

struct Node
{
    int x,y;
};

int Bfs(int n, int m)
{
    int i,j,num,t;
    Node now,next;
    queue<Node> q;
    num = 0;
    for(i = 1; i <= n; i++)
    {
        for(j = 1; j <= m; j++)
        {
            if(map[i][j] == '@')
            {
                num++;      //统计块数
                now.x = i;
                now.y = j;
                q.push(now);
                while(!q.empty())     //搜索遍历这一块所有节点
                {
                    now = q.front();
                    q.pop();
                    map[now.x][now.y] = '*';
                    for(t = 0; t < 8; t++)   //八个方向走
                    {
                        next.x = now.x+dir[t][0];
                        next.y = now.y+dir[t][1];
                        if(map[next.x][next.y] == '@')
                        {
                            map[next.x][next.y] = '*';     //把入队的改为*,防止重复
                            q.push(next);
                        }
                    }
                }
            }
        }
    }

    return num;
}

int main()
{
    Node p;
    int i,j,n,m,num;
    while(scanf("%d%d",&n,&m),n||m)
    {
        memset(map,'*',sizeof(map));
        for(i = 1; i <= n; i++)
        {
            for(j = 1; j <= m; j++)
            {
                //scanf("%c",&map[i][j]);
                cin >> map[i][j];
            }
        }
        num = Bfs(n,m);
        printf("%d\n",num);
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值