POJ 3711 Scout YYF I 概率DP + 矩阵快速幂

 
 
一段路上的某些位置有地雷,一个人从1开始,每一次走一步的概率是p,走两步的概率是1-p,问到达终点的概率。 题目本身是一个概率问题。假设dp[i]表示到达i点的概率,那么dp[i]=p*dp[i-1]+(1-p)*dp[i-2],且dp[1]=1,dp[2]=p,但是从题目的数据范围来看,无论是时间还是空间都不满足。 分析递推方程能看出,一个点的概率只与其前面的两个点有关,因此我们可以将其转换为矩阵相乘,我们定义矩阵A: 和B: ,第二个矩阵是初始状态,第一个矩阵是转换矩阵。A左乘B矩阵而如果不考虑后面的unknow,那么B矩阵完全可以用A矩阵代替。A左乘B之后可以得到下一个状态 ,当然A*B也是可以得到这个状态的。但是这并没有解决时空复杂度的问题。 有了上面的基础,下面我们对整个路径进行一下处理,即以地雷所在的位置为分割点进行分割,那么可以做到分割出的每一段都是只在路径的末端包含一个地雷,我们将平安通过每一段路称为一个独立事件,且这个事件的概率就是1减去到达这一段的地雷的概率,因为只要不踩到这个地雷,就可以顺利到达下一段,这样,我们利用矩阵的快速幂算出每一段的概率,再利用乘法定律,就可以得到答案。
Scout YYF I
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 7362Accepted: 2150

Description

YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties, YYF is now at the start of enemy's famous "mine road". This is a very long road, on which there are numbers of mines. At first, YYF is at step one. For each step after that, YYF will walk one step with a probability of p, or jump two step with a probality of 1- p. Here is the task, given the place of each mine, please calculate the probality that YYF can go through the "mine road" safely.

Input

The input contains many test cases ended with EOF. Each test case contains two lines. The First line of each test case is N (1 ≤ N ≤ 10) and p (0.25 ≤ p ≤ 0.75) seperated by a single blank, standing for the number of mines and the probability to walk one step. The Second line of each test case is N integer standing for the place of N mines. Each integer is in the range of [1, 100000000].

Output

For each test case, output the probabilty in a single line with the precision to 7 digits after the decimal point.

Sample Input

1 0.5
2
2 0.5
2 4

Sample Output

0.5000000
0.2500000

Source

 
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;


struct Matrix
{
    double mat[2][2];
};

Matrix mul(Matrix a,Matrix b)
{
    Matrix ret;
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<2;j++)
        {
            ret.mat[i][j]=0;
            for(int k=0;k<2;k++)
                ret.mat[i][j]+=a.mat[i][k]*b.mat[k][j];
        }
    }
    return ret;
}

Matrix pow_M(Matrix a,int n)
{
    Matrix ret;
    memset(ret.mat,0,sizeof(ret.mat));
    for(int i=0;i<2;i++)
        ret.mat[i][i]=1;
    Matrix temp=a;
    while(n)
    {
        if(n&1)
            ret=mul(ret,temp);
        temp=mul(temp,temp);
        n>>=1;
    }
    return ret;
}




int main()
{
    int n;
    int pos[20];
    double p;
    Matrix trans,tmp;
    while(cin>>n>>p)
    {
        trans.mat[0][0]=p;
        trans.mat[0][1]=1-p;
        trans.mat[1][0]=1;
        trans.mat[1][1]=0;
        for(int i=0;i<n;i++)
            scanf("%d",&pos[i]);
        sort(pos,pos+n);
        double ans=1.0;
        tmp=pow_M(trans,pos[0]-1);
        ans*=(1-tmp.mat[0][0]);
        for(int i=1;i<n;i++)
        {
            if(pos[i]==pos[i-1])
                continue;
            tmp=pow_M(trans,pos[i]-pos[i-1]-1);
            ans*=(1-tmp.mat[0][0]);
        }
        printf("%.7f\n",ans);
    }
    return 0;
}
 

查看原文:http://colorfulshark.cn/wordpress/scout-yyf1-1035.html
以下是Java解决POJ3233—矩阵幂序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速幂 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次幂矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速幂,matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值