POJ 2342 Anniversary party(树形DP)

题目链接:http://poj.org/problem?id=2342
Time Limit: 1000MS Memory Limit: 65536K

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output

Output should contain the maximal sum of guests’ ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

Source

Ural State University Internal Contest October’2000 Students Session

解题思路

题意大致是有一个聚会要邀请高校里的一些人,每人有一个搞笑值,但是如果两人存在直接的上下级关系就只能来其中一个,问如何使得这个聚会的搞笑值之和最大。

经典的树形DP,令dp[i][0]代表以i为根节点的子树中不选择i的最大搞笑值,dp[i][1]代表以i为根节点的子树中选择i的最大搞笑值,则有如下递推公式:

dp[i][0]=sum(max(dp[j][1],dp[j][0]))dp[i][1]=sum(dp[j][0])

其中j是i的子女节点。

AC代码

#include<bits/stdc++.h>
using namespace std;

int n,a,dp[6005][2],f[6005],vis[6005];

void treedp(int x)
{
    vis[x]=1;
    for(int i=1;i<=n;i++){
        if(!vis[i]&&f[i]==x){
            treedp(i);
            dp[x][0]+=max(dp[i][1],dp[i][0]);
            dp[x][1]+=dp[i][0];
        }
    }
}

int main()
{
    int x,y;
    while(~scanf("%d",&n)){
        if(!n){
            cin>>a;
            break;
        }
        for(int i=0;i<n;i++){
            scanf("%d",&a);
            dp[i+1][1]=a;
        }
        memset(f,0,sizeof(f));
        for(int i=1;i<n;i++){
            scanf("%d%d",&x,&y);
            f[x]=y;
        }
        int root=1;
        while(f[root])  root=f[root];
        memset(vis,0,sizeof(vis));
        treedp(root);
        printf("%d\n",max(dp[root][0],dp[root][1]));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值