POJ1703 Find them, Catch them

Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.


这道题一看很明显就能知道是并查集,

需要知道一点,因为只有两个帮派,

所以1和2是不同帮派,2和3不同帮派,那么1和3就是相同

帮派,每次只需要操作根节点就可以了,不同帮派的信息保存在

两个集合的根节点中,那样每次只需要查询根节点不同帮派的节点

是什么,然后合并就可以了。

#include <stdio.h>
const int maxn = 100005;
int dif[maxn], same[maxn];  //same表示为同一个集合,dif表示为不同集合的根节点
void init ( int n )
{
    for ( int i = 1; i <= n; i ++ )
        dif[i] = 0, same[i] = i;
}
int find ( int x )
{
    int r = x;
    while ( r != same[r] )
        r = same[r];
    int i = x, j;
    while ( i != r )
    {
        j = same[i];
        same[i] = r;
        i = j;
    }
    return r;
}
void Merge ( int x, int y, int d )
{
    int fx = find ( x ), fy = find ( y );
    if ( fx != fy )
    {
        same[fx] = fy;
        dif[d] = fy;    //重新设置节点的不同集合
    }
}
int main ( )
{
    int T, n, m, x, y, tx, ty, fx, fy;
    char op[2];
    scanf ( "%d", &T );
    while ( T -- )
    {
        scanf ( "%d%d", &n, &m );
        init ( n );
        while ( m -- )
        {
            scanf ( "%s%d%d", op, &x, &y );
            fx = find ( x ), fy = find ( y );
            //每次查找只需要查找所在根节点
            if ( op[0] == 'A' )
            {
                if ( fx == fy )
                    printf ( "In the same gang.\n" );
                else if ( dif[fx] == fy && dif[fy] == fx )  //不同集合
                    printf ( "In different gangs.\n" );
                else
                    printf ( "Not sure yet.\n" );
            }
            else
            {
                if ( dif[fx] == 0 )
                //如果没有不同的就不需要合并
                    dif[fx] = fy;
                else
                    Merge ( dif[fx], fy, fx );
                if ( dif[fy] == 0 )
                    dif[fy] = fx;
                else
                    Merge ( dif[fy], fx, fy );
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值