Tree Cutting

After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses. 

Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ. 

Please help Bessie determine all of the barns that would be suitable to disconnect.

Input

* Line 1: A single integer, N. The barns are numbered 1..N. 

* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.

Output

* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".

Sample Input

10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8

Sample Output

3
8
#include<iostream>
#include<cstring>
#include<algorithm>
#define N 10010
using namespace std;

int n,s,e,first[N],vis[N],ans[N];
struct node
{
    int x,y;
} que[2*N];

int dfs(int x)
{
    int num=0,sum=0;
    vis[x]=1;//标记
    int k=first[x],flag=0;//当前需要处理的队首顶点
    while(k!=-1)//扫描当前顶点所有的边
    {
        if(!vis[que[k].x])
        {
            num=dfs(que[k].x);
            sum+=num;
            if(num>n/2)
                flag=1;
        }
        k=que[k].y;
    }
    if(n-sum-1>n/2)
        flag=1;//判断情况是否符合条件
    if(!flag)
        ans[s++]=x;
    return sum+1;
}
int main()
{
    while(cin>>n)
    {
        memset(first,-1,sizeof(first));
        memset(vis,0,sizeof(vis));
        s=e=0;
        int a,b;
        for(int i=1; i<n; i++)
        {
            cin>>a>>b;//建立邻接表
            que[e].x=a;
            que[e].y=first[b];
            first[b]=e++;
            que[e].x=b;
            que[e].y=first[a];
            first[a]=e++;
        }
        a=dfs(1);
        if(s)
        {
            sort(ans,ans+s);
            for(int i=0; i<s; i++)
                cout<<ans[i]<<endl;
        }
        else
            cout<<"NONE"<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值