跑马

A Sweet Journey

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)


 

Input
In the first line there is an integer t (1≤t≤50), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers: Li,Ri, which represents the interval [Li,Ri] is swamp.
1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L.
Make sure intervals are not overlapped which means Ri<Li+1 for each i (1≤i<n).
Others are all flats except the swamps.
 

Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
 

Sample Input
1
2 2 2 5
1 2
3 4
 

Sample Output
Case #1: 0
 
#include<stdio.h>
int main()
{
	int ans=0,num=0,t,A,i,B,j,L,n,arr[101][101],power[101],use[101];
	scanf("%d",&t);
	while(t)
	{
		scanf("%d%d%d%d",&n,&A,&B,&L);
		for(i=0;i<n;i++)
			for(j=0;j<2;j++)
			{
				scanf("%d",&arr[i][j]);
				if(j==1)
				{
					use[i]=arr[i][j]-arr[i][j-1];
				}
				if(i==0)
					power[0]=arr[0][0];
				if(i!=0)
					power[i]=arr[i][0]-arr[i-1][1];
			}
		for(i=0;i<n;i++)
		{
			num=num+power[i];
			num=num-use[i];
			if(num<0)
			{
				ans=ans-num;
				num=0;
			}
		}
		printf("%d    ",ans);
		t--;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值