bzoj2527 [Poi2011]Meteors(整体二分+树状数组)

Description

Byteotian Interstellar Union (BIU) has recently discovered a new planet in a nearby galaxy. The planet is unsuitable for colonisation due to strange meteor showers, which on the other hand make it an exceptionally interesting object of study.
The member states of BIU have already placed space stations close to the planet’s orbit. The stations’ goal is to take samples of the rocks flying by. The BIU Commission has partitioned the orbit into msectors, numbered from 1to m, where the sectors 1and mare adjacent. In each sector there is a single space station, belonging to one of the nmember states.
Each state has declared a number of meteor samples it intends to gather before the mission ends. Your task is to determine, for each state, when it can stop taking samples, based on the meter shower predictions for the years to come.
Byteotian Interstellar Union有N个成员国。现在它发现了一颗新的星球,这颗星球的轨道被分为M份(第M份和第1份相邻),第i份上有第Ai个国家的太空站。

这个星球经常会下陨石雨。BIU已经预测了接下来K场陨石雨的情况。
BIU的第i个成员国希望能够收集Pi单位的陨石样本。你的任务是判断对于每个国家,它需要在第几次陨石雨之后,才能收集足够的陨石。
输入:
第一行是两个数N,M。
第二行有M个数,第i个数Oi表示第i段轨道上有第Oi个国家的太空站。
第三行有N个数,第i个数Pi表示第i个国家希望收集的陨石数量。
第四行有一个数K,表示BIU预测了接下来的K场陨石雨。
接下来K行,每行有三个数Li,Ri,Ai,表示第K场陨石雨的发生地点在从Li顺时针到Ri的区间中(如果Li<=Ri,就是Li,Li+1,...,Ri,否则就是Ri,Ri+1,...,m-1,m,1,...,Li),向区间中的每个太空站提供Ai单位的陨石样本。
输出:
N行。第i行的数Wi表示第i个国家在第Wi波陨石雨之后能够收集到足够的陨石样本。如果到第K波结束后仍然收集不到,输出NIE。
数据范围:

数据范围: 1<=n,m,k<=3*10^5 1<=Pi<=10^9 1<=Ai<10^9

Input

The first line of the standard input gives two integers, n and m(1<=n,m<=3*10^5) separated by a single space, that denote, respectively, the number of BIU member states and the number of sectors the orbit has been partitioned into.
In the second line there are mintegers Oi(1<=Oi<=n) separated by single spaces, that denote the states owning stations in successive sectors.
In the third line there are nintegers Pi(1<=Pi<=10^9) separated by single spaces, that denote the numbers of meteor samples that the successive states intend to gather.
In the fourth line there is a single integer k(1<=k<=3*10^5) that denotes the number of meteor showers predictions. The following klines specify the (predicted) meteor showers chronologically. The i-th of these lines holds three integers Li, Ri, Ai(separated by single spaces), which denote that a meteor shower is expected in sectors Li,Li+1,…Ri (if Li<=Ri) or sectors Li,Li+1,…,m,1,…Ri (if Li>Ri), which should provide each station in those sectors with Aimeteor samples (1<=Ai<10^9).
In tests worth at least 20% of the points it additionally holds that .

Output

 
Your program should print nlines on the standard output. The i-th of them should contain a single integer Wi, denoting the number of shower after which the stations belonging to the i-th state are expected to gather at least Pi samples, or the word NIE (Polish for no) if that state is not expected to gather enough samples in the foreseeable future.

Sample Input

3 5

1 3 2 1 3

10 5 7

3

4 2 4

1 3 1

3 5 2

Sample Output


3

NIE

1

[ Submit][ Status][ Discuss]


分析:
我一开始想的是:整体二分+线段树
针对每一个国家,我们都可以二分答案,我们就可以用整体二分的方法一次完成所有询问
因为我们每次更改的都是区间,所以就想到了线段树维护区间值

然而看到前辈的blog说线段树会T,需要用树状数组
那更好啊,树状数组即好写常数又小

总体思路:

  1. 二分区间答案M
  2. 判断当前国家在进行了M次流星雨后能不能满足需求,
    如果可以的话,该城市分到左区间;否则分到右区间
  3. 继续二分

看一下代码中比较难受的几点:

  • 我们用vector记录每个国家拥有哪些太空站
  • 我们需要添加一场流星雨,因为如果我们不添加的话,那些答案为NIE的国家ans计算出来是K
  • 此题中的树状数组,我们使用的是“区间加,单点查”的功能
  • 代码中有一个很跳脱的数组:id
    实际上ta就是我们二分的序列,代表1~n每个国家
  • q数组记录的就是每一场流星雨的信息
  • 但是solve中好像没有处理修改的操作啊
    当然有啊:注意这个T变量
T就是当前处理到的流星雨编号,这样记录既方便,又可以保证时间顺序
  • 注意区间修改的定义

tip

树状数组求前缀和,不要忘了累加器初始化为零

虽然一秒口胡做法
但是我对于整体二分的理解还没有10个小时,对于怎么实现还是一团迷糊。。。

//这里写代码片
#include<cstdio>
#include<cstring>
#include<iostream>
#include<vector>
#define ll long long

using namespace std;

const int INF=1e9+7;
const int N=300010;
int x[N],y[N],z[N],id[N],p[N],ans[N],tmp[N],n,m,K,T=0;
bool mark[N];
ll t[N];
vector <int> a[N];

void add(int x,ll z) {for (int i=x;i<=m;i+=(i&-i)) t[i]+=z;}
ll ask(int x) {ll ans=0;for (int i=x;i>0;i-=(i&(-i))) ans+=t[i];return ans;}

void insert(int now,int op)
{
    if (x[now]<=y[now])
    {
        add(x[now],op*z[now]);
        add(y[now]+1,-op*z[now]);
    }
    else
    {
        add(1,op*z[now]);
        add(y[now]+1,-op*z[now]);
        add(x[now],op*z[now]);
    }
}

void solve(int ql,int qr,int L,int R)
{
    if (ql>qr) return;
    if (L==R)
    {
        for (int i=ql;i<=qr;i++)
            ans[id[i]]=L;
        return;
    }

    int M=(L+R)>>1,cnt=0;                   //处理区间修改 
    while (T<=M) T++,insert(T,1);
    while (T>M) insert(T,-1),T--;

    for (int i=ql;i<=qr;i++)
    {
        ll tt=0;
        int now=id[i];
        for (int j=0;j<a[now].size();j++)   //累计当前收集了有多少陨石 
        {
            tt+=ask(a[now][j]);
            if (tt>=p[now]) break;
        }
        if (tt>=p[now]) mark[now]=1,cnt++;  //now国符合答案M 
        else mark[now]=0;
    }

    int l1=ql,l2=ql+cnt;
    for (int i=ql;i<=qr;i++)
        if (mark[id[i]]) tmp[l1++]=id[i];   //符合答案M的国家并入左区间 
        else tmp[l2++]=id[i];
    for (int i=ql;i<=qr;i++) id[i]=tmp[i];

    solve(ql,ql+cnt-1,L,M);
    solve(ql+cnt,qr,M+1,R);
}

int main()
{
    scanf("%d%d",&n,&m);
    int u,w,v;
    for (int i=1;i<=m;i++)
    {
        scanf("%d",&u);
        a[u].push_back(i);
    }
    for (int i=1;i<=n;i++) scanf("%d",&p[i]);
    scanf("%d",&K);
    for (int i=1;i<=K;i++)
        scanf("%d%d%d",&x[i],&y[i],&z[i]);
    K++; x[K]=1; y[K]=m; z[K]=INF;     
    //添加一场流星雨,方便处理 
    for (int i=1;i<=n;i++) id[i]=i;   //一共有i个国家

    solve(1,n,1,K);
    for (int i=1;i<=n;i++)
        if (ans[i]!=K) printf("%d\n",ans[i]);
        else printf("NIE\n");

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值