题目1162:I Wanna Go Home

题目描述:

    The country is facing a terrible civil war----cities in the country are divided into two parts supporting different leaders. As a merchant, Mr. M does not pay attention to politics but he actually knows the severe situation, and your task is to help him reach home as soon as possible.
    "For the sake of safety,", said Mr.M, "your route should contain at most 1 road which connects two cities of different camp."
    Would you please tell Mr. M at least how long will it take to reach his sweet home?

输入:

    The input contains multiple test cases.
    The first line of each case is an integer N (2<=N<=600), representing the number of cities in the country.
    The second line contains one integer M (0<=M<=10000), which is the number of roads.
    The following M lines are the information of the roads. Each line contains three integers A, B and T, which means the road between city A and city B will cost time T. T is in the range of [1,500].
    Next part contains N integers, which are either 1 or 2. The i-th integer shows the supporting leader of city i.
    To simplify the problem, we assume that Mr. M starts from city 1 and his target is city 2. City 1 always supports leader 1 while city 2 is at the same side of leader 2.
    Note that all roads are bidirectional and there is at most 1 road between two cities.
Input is ended with a case of N=0.

输出:

    For each test case, output one integer representing the minimum time to reach home.
    If it is impossible to reach home according to Mr. M's demands, output -1 instead.

样例输入:
2
1
1 2 100
1 2
3
3
1 2 100
1 3 40
2 3 50
1 2 1
5
5
3 1 200
5 3 150
2 5 160
4 3 170
4 2 170
1 2 2 2 1
0
样例输出:
100
90
540
import java.io.FileReader;
import java.io.InputStreamReader;
import java.io.IOException;
import java.io.BufferedReader;
import java.util.Scanner;
import java.util.Queue;
import java.util.Arrays;
import java.util.LinkedList;

class Main
{
	public static final boolean DEBUG = false;
	public static int N = 610;;
	public static int[][] f;
	public static int n;
	public static int[] leader;
	
	public static void bfs()
	{
		Queue<Integer> q = new LinkedList<Integer>();
		q.add(Integer.valueOf(1));
		int[][] dis = new int[n + 1][2];
		
		for (int i = 1; i <= n; i++) {
			dis[i][0] = dis[i][1] = Integer.MAX_VALUE;
		}
		
		dis[1][0] = dis[1][1] = 0;
		
		while (!q.isEmpty()) {
			int u = q.poll().intValue();
			
			for (int v = 1; v <= n; v++) {
				if (f[u][v] != 0) {
					boolean ok = false;
					if (leader[u] == leader[v]) {
						if (dis[u][0] != Integer.MAX_VALUE && dis[u][0] + f[u][v] < dis[v][0]) {
							dis[v][0] = dis[u][0] + f[u][v];
							ok = true;
						} 
						
						if (dis[u][1] != Integer.MAX_VALUE && dis[u][1] + f[u][v] < dis[v][1]) {
							dis[v][1] = dis[u][1] + f[u][v];
							ok = true;
						}
					} else {
						if (dis[u][0] != Integer.MAX_VALUE && dis[u][0] + f[u][v] < dis[v][1]) {
							dis[v][1] = dis[u][0] + f[u][v];
							ok = true;
						} 
						
					}
					
					if (ok) q.add(Integer.valueOf(v));
				}
			}
		}
		
		int ans = Integer.MAX_VALUE;
		for (int i = 0; i < 2; i++) {
			ans = Math.min(dis[2][i], ans);
		}
		
		if (ans == Integer.MAX_VALUE) System.out.println(-1);
		else System.out.println(ans);
		
	}
	
	public static void main(String[] args) throws IOException
	{
		Scanner cin;
		int m;
		
		if (DEBUG) {
			cin = new Scanner(new FileReader("d:\\OJ\\uva_in.txt"));
		} else {
			cin = new Scanner(new InputStreamReader(System.in));
		}
		
		f = new int[N][N];
		
		while (cin.hasNext()) {
			n = cin.nextInt();
			if (n == 0) break;
			
			m = cin.nextInt();
			
			for (int i = 0; i < N; i++) Arrays.fill(f[i], 0);
			
			//System.out.println("n = " + n + " m = " + m);
			for (int i = 0; i < m; i++) {
				int u, v, w;
				u = cin.nextInt();
				v = cin.nextInt();
				w = cin.nextInt();
				f[u][v] = f[v][u] = w;
			}
			
			leader = new int[n + 1];
			for (int i = 1; i <= n; i++) leader[i] = cin.nextInt();
			
			bfs();
			
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值