hdu1316 How Many Fibs?

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3613    Accepted Submission(s): 1451


Problem Description
Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].
 

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
 

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.
 

Sample Input
  
  
10 100 1234567890 9876543210 0 0
 

Sample Output
  
  
5 4
import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.io.FileReader;
import java.io.PrintWriter;
import java.io.OutputStreamWriter;
import java.io.StreamTokenizer;
import java.util.StringTokenizer;
import java.io.IOException;
import java.math.BigInteger;

class Main
{
	public static final boolean DEBUG = false;
	public StringTokenizer tokenizer;
	public PrintWriter cout;
	BufferedReader cin;
	
	
	public void init() throws IOException
	{		
		if (DEBUG) {
			cin = new BufferedReader(new FileReader("d:\\OJ\\uva_in.txt"));
		} else {
			cin = new BufferedReader(new InputStreamReader(System.in));
		}
		tokenizer = new StringTokenizer("");
		
		cout = new PrintWriter(new OutputStreamWriter(System.out));	
		
	}
	
	public String next() throws IOException
	{
		while (!tokenizer.hasMoreTokens()) {
			tokenizer = new StringTokenizer(cin.readLine());
		}
		
		return tokenizer.nextToken();
	}
	
	public void solve(String a, String b)
	{
		BigInteger ba = new BigInteger(a);
		BigInteger bb = new BigInteger(b);
		BigInteger f1 = BigInteger.ONE;
		BigInteger f2 = BigInteger.valueOf(2);
		
		BigInteger tmp;
		while (true) {
			tmp = f1.add(f2);
			
			if (f1.compareTo(ba) >= 0) break;
			f1 = f2;
			f2 = tmp;
		}
		
		BigInteger ans = BigInteger.ZERO;
		while (true) {
			tmp = f1.add(f2);
			if (f1.compareTo(bb) > 0) break;
			ans = ans.add(BigInteger.ONE);
			f1 = f2;
			f2 = tmp;
		}
		
		cout.println(ans.toString());
		cout.flush();
	} 
	
	public static void main(String[] args) throws IOException
	{
		Main solver = new Main();
		solver.init();
		String a, b;
		
		while (true) {
			a = solver.next();
			b = solver.next();
			if ("0".equals(a) && "0".equals(b)) break;
			solver.solve(a, b);
		}
		
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值