题目1022:游船出租

/*
题目描述:
        现有公园游船租赁处请你编写一个租船管理系统。当游客租船时,管理员输入船号并按下S键,系统开始计时;当游客还船时,管理员输入船号并按下E键,系统结束计时。船号为不超过100的正整数。当管理员将0作为船号输入时,表示一天租船工作结束,系统应输出当天的游客租船次数和平均租船时间。
        注意:由于线路偶尔会有故障,可能出现不完整的纪录,即只有租船没有还船,或者只有还船没有租船的纪录,系统应能自动忽略这种无效纪录。

输入:

        测试输入包含若干测试用例,每个测试用例为一整天的租船纪录,格式为:
        船号(1~100) 键值(S或E) 发生时间(小时:分钟)
        每一天的纪录保证按时间递增的顺序给出。当读到船号为-1时,全部输入结束,相应的结果不要输出。

输出:
        对每个测试用例输出1行,即当天的游客租船次数和平均租船时间(以分钟为单位的精确到个位的整数时间)。

样例输入:

    1 S 08:10
    2 S 08:35
    1 E 10:00
    2 E 13:16
    0 S 17:00
    0 S 17:00
    3 E 08:10
    1 S 08:20
    2 S 09:00
    1 E 09:20
    0 E 17:00
    -1

样例输出:

    2 196
    0 0
    1 60

 *
 */
#include <cstdio>
#include <cstring>
#include <set>
#include <iostream>
#include <cmath>

using namespace std;

const int N = 60;

struct Info
{
	int no;
	int start;
	bool operator == (const Info &b)const {
		return no == b.no;
	}
	bool operator < (const Info &b)const {
		return no < b.no;
	}
};

struct Result
{
	int no;
	int t;
	bool operator < (const Result &b)const {
		return no < b.no;
	}
};

int main()
{
	char buf[N];

#ifndef ONLINE_JUDGE
	freopen("e:\\uva_in.txt", "r", stdin);
#endif

	set<Info> s;
	set<Result> result;

	while (gets(buf) && strcmp(buf, "-1") != 0) {
		int no;
		char ch;
		char tmp[N];
		Info info;

		sscanf(buf, "%d %c%s", &no, &ch, tmp);
		//cout << "no:" << no << " ch:" << ch << " tmp:" << tmp << endl;
		if (no != 0) {
			info.no = no;
			int hour, min;
			sscanf(tmp, "%d:%d", &hour, &min);
			set<Info>::iterator pos = s.find(info);
			if (pos == s.end()) {
				if (ch == 'S') {
					info.start = hour * 60 + min;
					s.insert(info);
				}
			} else {
				Result res;
				if (ch == 'E') {
					res.no = no;
					res.t = hour * 60 + min - pos->start;
					result.insert(res);
				}
			}
		} else {
			double ans = 0;
			for (set<Result>::iterator i = result.begin(); i != result.end(); i++) {
				ans += i->t;
			}
			printf("%d %d\n", result.size(), result.size()?(int)(ans / result.size() + 0.5):0);
			s.clear();
			result.clear();
		}
	}

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值