POJ 2187(计算几何+旋转卡壳法或暴力)

问题描述:

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates. 

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm 

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other. 

Sample Input

4
0 0
0 1
1 1
1 0
Sample Output

2

题目题意:题目给我们n个点,让我们求出俩个点最远的距离的平方。

题目分析:我们先由那几个点,构建一个凸包,那俩个点肯定在凸包上,然后我们可以通过旋转卡壳法来求最远距离,可以去看挑战程序设计竞赛,还可以去看看这篇博客!

点击打开链接

不过这题还可以O(n^2) 暴力过!

代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;

const int MAXN=50000+200;

struct point
{
    int x,y;
};
point list[MAXN];//凸包的点
int stack[MAXN],top;//stack保存的是最后凸包的点的序号

int cross(point p0,point p1,point p2) //计算叉积  p0p1 X p0p2
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p1.y-p0.y)*(p2.x-p0.x);
}
double dis(point p1,point p2)  //计算 p1p2的 距离
{
    return sqrt((double)(p2.x-p1.x)*(p2.x-p1.x)+(p2.y-p1.y)*(p2.y-p1.y));
}
bool cmp(point p1,point p2) //极角排序函数 , 角度相同则距离小的在前面
{
    int tmp=cross(list[0],p1,p2);
    if(tmp>0) return true;
    else if(tmp==0&&dis(list[0],p1)<dis(list[0],p2)) return true;
    else return false;
}
void init(int n) //输入,并把  最左下方的点放在 list[0]  。并且进行极角排序
{
    int i,k;
    point p0;
    scanf("%d%d",&list[0].x,&list[0].y);
    p0.x=list[0].x;
    p0.y=list[0].y;
    k=0;
    for(i=1;i<n;i++)
    {
        scanf("%d%d",&list[i].x,&list[i].y);
        if( (p0.y>list[i].y) || ((p0.y==list[i].y)&&(p0.x>list[i].x)) )
        {
            p0.x=list[i].x;
            p0.y=list[i].y;
            k=i;
        }
    }
    list[k]=list[0];
    list[0]=p0;

    sort(list+1,list+n,cmp);
}

void graham(int n)
{
    int i;
    if(n==1) {top=0;stack[0]=0;}
    if(n==2)
    {
        top=1;
        stack[0]=0;
        stack[1]=1;
    }
    if(n>2)
    {
        for(i=0;i<=1;i++) stack[i]=i;
        top=1;

        for(i=2;i<n;i++)
        {
            while(top>0&&cross(list[stack[top-1]],list[stack[top]],list[i])<=0) top--;
            top++;
            stack[top]=i;
        }
    }
}
double get_dis(int a,int b)
{
    return (double ) (list[a].x-list[b].x)*(list[a].x-list[b].x)+(list[a].y-list[b].y)*(list[a].y-list[b].y);
}
int main()
{
    int n;
    while (scanf("%d",&n)!=EOF) {
        init(n);
        graham(n);//构建凸包
        double ans=0;//暴力也可以过
       /* for (int i=0;i<top;i++) {
            for (int j=i+1;j<=top;j++) {
                ans=max(ans,get_dis(stack[i],stack[j]));
            }
        }
        */
        stack[++top]=stack[0];//旋转卡壳法
        int p=1;
        for (int i=0;i<top;i++) {
            while (cross(list[stack[i]],list[stack[i+1]],list[stack[p+1]])>cross(list[stack[i]],list[stack[i+1]],list[stack[p]]))
                p=(p+1)%top;
            ans=max(ans,max (get_dis(stack[i],stack[p]),get_dis(stack[i+1],stack[p])));
        }
        printf("%.0f\n",ans);
    }
    return 0;
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值