HDU4472 Count DP

Count

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2148    Accepted Submission(s): 1421


Problem Description
Prof. Tigris is the head of an archaeological team who is currently in charge of an excavation in a site of ancient relics.
This site contains relics of a village where civilization once flourished. One night, examining a writing record, you find some text meaningful to you. It reads as follows.
“Our village is of glory and harmony. Our relationships are constructed in such a way that everyone except the village headman has exactly one direct boss and nobody will be the boss of himself, the boss of boss of himself, etc. Everyone expect the headman is considered as his boss’s subordinate. We call it relationship configuration. The village headman is at level 0, his subordinates are at level 1, and his subordinates’ subordinates are at level 2, etc. Our relationship configuration is harmonious because all people at same level have the same number of subordinates. Therefore our relationship is …”
The record ends here. Prof. Tigris now wonder how many different harmonious relationship configurations can exist. He only cares about the holistic shape of configuration, so two configurations are considered identical if and only if there’s a bijection of n people that transforms one configuration into another one.
Please see the illustrations below for explanation when n = 2 and n = 4.

The result might be very large, so you should take module operation with modules 10 9 +7 before print your answer.
 

Input
There are several test cases.
For each test case there is a single line containing only one integer n (1 ≤ n ≤ 1000).
Input is terminated by EOF.
 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is the desired answer.
 

Sample Input
  
  
1 2 3 40 50 600 700
 

Sample Output
  
  
Case 1: 1 Case 2: 1 Case 3: 2 Case 4: 924 Case 5: 1998 Case 6: 315478277 Case 7: 825219749
 


题意:有n个人,图表示上下级关系,对于同一级的人来说,每个人拥有属下的数量是一样的,问不同的组合方式有多少种。

dp[i]表示当某个状态的最后一层有i个节点的时候,组合的方法数,总共的方法数就是1~n-1种结尾方式组合数的和。

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
const __int64 mod=1e9+7;
using namespace std;
 
__int64 dp[1009];
 
int main()
{
    int n;
    int ca=1;
    while(~scanf("%d",&n))
    {
        if(n==1)
        {
            printf("Case %d: %d\n",ca++,1);
            continue;
        }
        memset(dp,0,sizeof dp);
 
        dp[n-1]=1;
        //dp[1]=1;
        for(int i=n-1;i>=2;i--)
        {
            for(int j=i/2;j<i;j++)//向下扩展时候,每次拿j个节点下来,使得拿下的j个节点均匀分在(i-j)个节点下方
            {
                if(j%(i-j)==0)
                {
                    dp[(j/(i-j))]=(dp[(j/(i-j))]+dp[i])%mod;
                }
            }
        }
        __int64 ans=0;
        for(int i=1;i<=n;i++)
        {
            ans=(ans+dp[i])%mod;
             //cout<<dp[i]<<endl;
        }
       // cout<<ans<<endl;
        printf("Case %d: %I64d\n",ca++,ans);
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值