hdu3038 How many answers are wrong【并查集】

TT and FF are ... friends. Uh... very very good friends -________-b 

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored). 

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers. 

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose. 

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence. 

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed. 

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers. 

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy) 
Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions. 

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N. 

You can assume that any sum of subsequence is fit in 32-bit integer. 
Output
A single line with a integer denotes how many answers are wrong.
Sample Input
10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1
Sample Output
1

这题目出的也是很冗长了....

简而言之就是 告诉你 a-b的数的总和为sum

问你有多少组是矛盾的 也就是错误的


并查集 把rank数组用来记录根节点表示的数到这个节点表示的数的总和

合并的时候更新他们之间的关系

压缩路径的时候也需要更新父节点和子节点之间的关系【这个写的时候忘记了】

最后要注意 区间需要左开右闭 只有这样区间相加的时候才不会出错

比如(a, b] + (b, c] 才会是(a, c] sum才不会出错 所以a需要-=1


#include <iostream>
#include <algorithm>
#include <stdlib.h>
#include <cstring>
#include <vector>
#include <map>
#include <set>
#include <stdio.h>
#include <queue>
#include <stack>
#define inf 0x3f3f3f3f

using namespace std;

const int maxn = 200005;
int n, m;
int parent[maxn];
int ran[maxn];

void init(int n)
{
    int i;
    for(int i = 0; i <= n; i++){
        parent[i] = i;
        ran[i] = 0;
    }
}

int fin(int x)
{
    if(x != parent[x]){
        int f = parent[x];
        parent[x] = fin(parent[x]);
        ran[x] += ran[f];
    }
        //parent[x] = fin(parent[x]);
    return parent[x];
}

void mer(int x, int y, int s)
{
    int tx = fin(x);
    int ty = fin(y);
    if(tx != ty){
        parent[tx] = ty;
        ran[tx] = ran[y] - ran[x] + s;
    }
}

int main()
{
    while(cin>>n>>m){
        int cnt = 0;
        init(n);
        for(int i = 0; i < m; i++){
            int a, b, s;
            cin>>a>>b>>s;
            a -= 1;
            int ta = fin(a);
            int tb = fin(b);
            if(ta != tb){
                /*if(s < ran[a] && s < ran[b]){
                    cnt++;
                }
                else*/{
                    mer(a, b, s);
                }
            }
            else{
                if(ran[a] - ran[b] != s){
                    cnt++;
                }
            }
        }

        cout<<cnt<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值