hd1342 Lotto【数字排列】

Lotto

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1778    Accepted Submission(s): 863


Problem Description
In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k>6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34].

Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.
 

Input
The input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k.
 

Output
For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case.
 

Sample Input
  
  
7 1 2 3 4 5 6 7 8 1 2 3 5 8 13 21 34 0
 

Sample Output
1 2 3 4 5 6
1 2 3 4 5 7
1 2 3 4 6 7
1 2 3 5 6 7
1 2 4 5 6 7
1 3 4 5 6 7
2 3 4 5 6 7

1 2 3 5 8 13
1 2 3 5 8 21
1 2 3 5 8 34
1 2 3 5 13 21
1 2 3 5 13 34
1 2 3 5 21 34
1 2 3 8 13 21
1 2 3 8 13 34
1 2 3 8 21 34
1 2 3 13 21 34
1 2 5 8 13 21
1 2 5 8 13 34
1 2 5 8 21 34
1 2 5 13 21 34
1 2 8 13 21 34
1 3 5 8 13 21
1 3 5 8 13 34
1 3 5 8 21 34
1 3 5 13 21 34
1 3 8 13 21 34
1 5 8 13 21 34
2 3 5 8 13 21
2 3 5 8 13 34
2 3 5 8 21 34
2 3 5 13 21 34
2 3 8 13 21 34
2 5 8 13 21 34
3 5 8 13 21 34
嗯,题目大意就是说,给一n代表数字个数,然后从中挑选6个数进行从小到大排列。
嗯,至于数字非去重全排列、去重全排列以及去重从小到大排的代码请看上一篇
这里给出这道题的三种解决方式,
这一种就普通的
#include<cstdio>//15ms
#include<cstring>
int arr[15],a[10],mark[15];
int n;
void dfs(int k)
{
    if(k>6)
    {
        for(int i=1;i<6;++i)
            printf("%d ",a[i]);
        printf("%d\n",a[6]);
        return ;
    }
    else 
    {
        for(int i=0;i<n;++i)
        {
            if(!mark[i]&&arr[i]>a[k-1])
            {
                a[k]=arr[i];
                mark[i]=1;
                dfs(k+1);
                mark[i]=0;
            }
        }
    }
}
int main()
{
    int cnt=0;
    while(scanf("%d",&n)&&n)
    {
        cnt++;
        memset(mark,0,sizeof(mark));
        memset(arr,0,sizeof(arr));
        for(int i=0;i<n;++i)
            scanf("%d",&arr[i]);
        a[0]=0;
        if(cnt!=1)
            printf("\n");
        dfs(1);
    }
    return 0;
}
这个是同学想出来的方法,昨天木下载,今天自己写了调试了快一上午了,应该有些地方不一样只是个思想。。。。。
#include<cstdio>//0ms
#include<cstring>
#include<algorithm>
using namespace std;
int a[10],arr[15];
int n;
void dfs(int pos,int tot)//传参是pos表示目前该取arr数组的第几位了,tot表示目前a数组里该存第几位了
{
	if(n-pos-1<5-tot)//这里表示当arr数组里剩余的数字即使放到a数组里也不够6位了,就直接return 掉
		return ;
	if(tot>=6)
	{
		for(int i=0;i<5;++i)
			printf("%d ",a[i]);
		printf("%d\n",a[5]);
		return ;
	}
	for(int i=pos;i<n;++i)
	{
		a[tot]=arr[i];
		dfs(i+1,tot+1);
	}
}
int main()
{
	int cnt=0;
	while(scanf("%d",&n)&&n)
	{
		for(int i=0;i<n;++i)
			scanf("%d",&arr[i]);
		sort(arr,arr+n);//我这里排序之后不用比较
		if(cnt)
			printf("\n");
		dfs(0,0);
		cnt++;
	}
	return 0;
}

这个是大神的思想,每个数都有两种可能既用或不用
#include<cstdio>//0ms
#include<cstring>
#include<algorithm>
using namespace std;
int n,a[10],arr[15];
void dfs(int pos,int num)
{
	if(n-pos-1<5-num)
		return ;
	if(num>=6)
	{
		for(int i=0;i<5;++i)
			printf("%d ",a[i]);
		printf("%d\n",a[5]);
		return ;
	}
	a[num]=arr[pos];
	dfs(pos+1,num+1);//用这个数了
	dfs(pos+1,num);//不用这个数
}
int main()
{
	int cnt=0;
	while(scanf("%d",&n)&&n)
	{
		for(int i=0;i<n;++i)
			scanf("%d",&arr[i]);
		sort(arr,arr+n);
		if(cnt)
			printf("\n");
		dfs(0,0); 
		cnt++;
	} 
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值