PAT(甲级)1014. Waiting in Line (30)

Waiting in Line (30)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer[i] will take T[i] minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output “Sorry” instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry

题目大意:银行用n个窗口 每个窗口前可以排m个人 总共k个人然后从n*m+1个人开始 在线外等待 按顺序选择当前最短的队去排队 然后q个询问 每个询问是一个人的序号 问他/她什么时候能完成事务
分析:队列模拟排队 想麻烦了 先存了前n*m个人的完成时间 然后从n*m+1个人开始 选择排哪个队 优先队列里放n个窗口中当前服务对象的完成时间 窗口号 队中序号 然后取出时间最小的那个放进去下一个服务对象 同时让线外的人进去一个并记录完成时间
也有人模拟时间流逝 每分钟检测一次 因为是有限时的08-17点 所以是可以行的通的
坑点: 开始被服务时间小于17:00即可被服务。。。。英语渣渣的我开始写的是完成服务时间大于17:00不可被服务

/*测试数据
2 2 9 9
1 2 6 4 3 1 9 100 534
1 2 3 4 5 6 7 8 9
08:01 08:02 08:07 08:06 08:10 08:07 08:16 09:50 17:10
*/
#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define maxn 1010
using namespace std;
int n,m,k,q;
struct node{
    long long t;//w号窗口第n个人的完成时间 即w号窗口当前服务对象的事务完成时间
    int w,n;//w窗口号 n此窗口前第n个人 从开始计数
    friend bool operator < (node a,node b){
        if(a.t==b.t)//完成时间相等 则选窗口号小的
            return a.w > b.w;
        else
            return a.t > b.t;
    }
};
int main()
{
    long long rec[maxn],time[maxn];//time记录所有人完成事务时间
    long long tem[21][maxn];//记录每个窗口前排队的人的事务完成时间
    int query;
    priority_queue<node>pq;
    scanf("%d%d%d%d",&n,&m,&k,&q);
    for(int i=1;i<=k;++i)
        scanf("%ld",&rec[i]);
    for(int i=0;i<21;++i){//初始化
        for(int j=0;j<100;++j)
            tem[i][j]=0;
    }
    int cnt=1;
    for(int i=1;i<=m&&cnt<=k;++i){//前n*m个人
        for(int j=1;j<=n&&cnt<=k;++j){
            tem[j][i]=tem[j][i-1]+rec[cnt];
            time[cnt]=tem[j][i];
            cnt++;
        }
    }
    for(int i=1;i<=n;++i){//将每个窗口前第一个服务对象放进去
        node E={tem[i][1],i,1};
        pq.push(E);
    }
    while(cnt<=k&&!pq.empty()){
        node now=pq.top();
        pq.pop();
        tem[now.w][now.n+m]=tem[now.w][now.n+m-1]+rec[cnt];//将线外的人放进去一个
        time[cnt]=tem[now.w][now.n+m];//记录此人的完成时间
        cnt++;
        node E={tem[now.w][now.n+1],now.w,now.n+1};//队列中放进去此窗口的下一个服务对象
        pq.push(E);
    }
    while(q--){
        scanf("%d",&query);
        if(time[query]-rec[query]>=(17-8)*60){//开始服务时间要小于17:00
            printf("Sorry\n");
            continue;
        }
        int h=time[query]/60;
        int m=time[query]%60;
        h=h+8;
        printf("%02d:%02d\n",h,m);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值