利用单个三层交换机实现不同vlan和不同网段之间互通(华为和cisco)

网络 专栏收录该内容
19 篇文章 0 订阅

作者:【吴业亮】

博客:http://blog.csdn.net/wylfengyujiancheng

一、华为三层交换机实现不同网段和不同vlan间互通
目标实现:pc1和pc2之间互通
1、拓扑图
这里写图片描述
2、三层交换机配置:

<S1>display current-configuration 
#sysname S1
#VLAN batch 2 3
#interface VLANif2
 ip address 192.168.8.1 255.255.255.0
#interface VLANif3
 ip address 172.16.8.1 255.255.255.0
#interface GigabitEthernet0/0/1
 port link-type access
 port default VLAN 2
#interface GigabitEthernet0/0/2
 port link-type access
 port default VLAN 3

3、pc配置
pc1:
这里写图片描述
Pc2:
这里写图片描述
4、测试
Pc1上测试
这里写图片描述
pc2上测试
这里写图片描述
二、通过cisco三层交换机实现不同网段和不同vlan间互通
目标实现:pc1和pc2之间互通
1、拓扑
这里写图片描述
2、配置交换机:
我们要用S1 来实现分别处于VLAN1 和VLAN2 的PC1 和PC2 间的通信。首先在S1 上划分VLAN,配置命令为:
创建vlan

S1(config)#vlan 3
S1(config-vlan)#exit
S1(config)#vlan 2
S1(config-vlan)#exit

在接口1和接口2上配置vlan

S1(config)#int f0/1
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 2
S1(config-if)#int f0/2
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 3

创建虚拟vlan,为VLAN1和VLAN2配置网关,即是PC1,PC2的网关,配置命令为:

S1(config)#int vlan 2
S1(config-if)#no shutdown
S1(config-if)#ip address 192.168.8.1 255.255.255.0
S1(config)#int vlan 3
S1(config-if)#no shutdown
S1(config-if)#ip address 172.16.8.1 255.255.255.0

配置三层交换,配置命令为:

S1(config)#ip routing    
//以上开启S1 的路由功能,这时S1 就启用了三层功能。

查看路由表
这里写图片描述
3、配置pc
这里写图片描述
这里写图片描述
4、测试:
Pc1上
这里写图片描述
Pc2上
这里写图片描述

  • 22
    点赞
  • 7
    评论
  • 88
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2020 CSDN 皮肤主题: 猿与汪的秘密 设计师:白松林 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值