解决Eclipse无法安装STS

版权声明:作者:N3verL4nd 出处: https://blog.csdn.net/lgh1992314/article/details/64474130

使用Eclipse Neon安装Spring Tool Suite报错:


Cannot complete the install because one or more required items could not be found.
  Software being installed: Spring IDE OSGi Extension (optional) 3.8.3.201612191259-RELEASE (org.springframework.ide.eclipse.osgi.feature.feature.group 3.8.3.201612191259-RELEASE)
  Missing requirement: Spring IDE Live Beans Graph 3.8.3.201612191259-RELEASE (org.springframework.ide.eclipse.beans.ui.livegraph 3.8.3.201612191259-RELEASE) requires 'bundle org.eclipse.zest.core [1.0.0,2.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: Spring IDE Core (required) 3.8.3.201612191259-RELEASE (org.springframework.ide.eclipse.feature.feature.group 3.8.3.201612191259-RELEASE)
    To: org.springframework.ide.eclipse.beans.ui.livegraph [3.8.3.201612191259-RELEASE]
  Cannot satisfy dependency:
    From: Spring IDE OSGi Extension (optional) 3.8.3.201612191259-RELEASE (org.springframework.ide.eclipse.osgi.feature.feature.group 3.8.3.201612191259-RELEASE)
    To: org.springframework.ide.eclipse.feature.feature.group 0.0.0
原因是没有安装STS依赖的GEF插件
解决办法:

启动eclipse,点击window——>preferences——>install/update——>available software sites,点击Add
添加如下信息:
GEF

http://download.eclipse.org/tools/gef/updates/releases/
安装GEF插件

然后再重新安装sts插件



以 Luna 为例,点击 HelpInstall New Software...Available Software Sites 可以看到所有的更新源,将其中的download.eclipse.org全部替换成mirrors.ustc.edu.cn/eclipse即可。


当我们观察到Eclipse到download.eclipse.org下载插件时,

我们就关闭此次下载,做如上修改,再继续下载,这样反复几次就可以下载成功了。




参考:

http://forum.spring.io/forum/spring-projects/springsource-tool-suite/121775-cannot-install-spring-tool-suite-sts-for-eclipse-juno-3-8-4-2-3-1-0-release

http://stackoverflow.com/questions/14068135/spring-ide-installation-error

http://www.xie4ever.com/2016/12/08/eclipse%E6%97%A0%E6%B3%95%E5%AE%89%E8%A3%85sts%E6%8F%92%E4%BB%B6%E7%9A%84%E9%97%AE%E9%A2%98/


没有更多推荐了,返回首页