魔咒词典

魔咒词典

Time Limit : 8000/5000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 41   Accepted Submission(s) : 12
Problem Description
哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
 

Input
首先列出词典中不超过100000条不同的魔咒词条,每条格式为: [魔咒] 对应功能 其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。 词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。
 

Output
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
 

Sample Input
  
  
[expelliarmus] the disarming charm [rictusempra] send a jet of silver light to hit the enemy [tarantallegra] control the movement of one's legs [serpensortia] shoot a snake out of the end of one's wand [lumos] light the wand [obliviate] the memory charm [expecto patronum] send a Patronus to the dementors [accio] the summoning charm @END@ 4 [lumos] the summoning charm [arha] take me to the sky
 

Sample Output
  
  
light the wand accio what? what?
本题很简单,就是从名字找内容,从内容找名字,直接两个string数组for循环比较
#include<iostream>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<map>
using namespace std;
int main(){

    string a;
    string s1[100003];
    string s2[100003];
    int t=0;
    while(cin>>a){
        char c[100];
        string b;
        if(a=="@END@") break;
        gets(c);
        for(int i=1;i<strlen(c);i++)
            b+=c[i];
        //cout<<a<<b;
        s1[t]=a;
        s2[t]=b;
        t++;
    }
    int m;
    scanf("%d\n",&m);
    while(m--){
        string b;
        char c[100];
        gets(c);
        for(int i=0;i<strlen(c);i++)
             b+=c[i];
        if(c[0]=='[')
           {
                int h=-1;
                for(int i=0;i<t;i++)
                {
                    //cout<<b<<s1[i]<<endl;
                    if(s1[i]==b)
                    {
                        h=i;
                        break;
                    }
                }
                if(h!=-1)
                    cout<<s2[h]<<endl;
                else
                printf("what?\n");
            }
        else{
                int h=-1;
                for(int i=0;i<t;i++)
                {
                    if(s2[i]==b)
                    {
                        h=i;
                        break;
                    }
                }
                if(h!=-1)
                {
                    for(int i=1;i<s1[h].length()-1;i++)
                        printf("%c",s1[h][i]);
                    printf("\n");
                }
                else
                {
                  printf("what?\n");
                }
            }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值