10-排序6 Sort with Swap(0, i)(25 分)

Given any permutation of the numbers {0, 1, 2,..., N1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (105) followed by a permutation sequence of {0, 1, ..., N1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9
#include <iostream>
#include <algorithm> 
#include <stdio.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace std;
int a[100009],b[100009];
int n;
bool check()
{
	for(int i=0;i<n;i++)
	{
		if(a[i]!=b[i])
		{
			return false;
		}
	}
	return true;
}
int main(int argc, char *argv[]) {
	int index,cnt=0;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		cin>>a[i];
		b[i]=a[i];
	}
	sort(a,a+n);
	for(int i=0;i<n;i++)
	{
		if(b[i]==0)
		{
			index=i;
			break;
		}
	}
	while(!check())
	{
		for(int i=0;i<n;i++)
		{
			if(b[i]==index)
			{
				cnt++;
				swap(b[index],b[i]);
				index=i;
				break;
			}
		}
		if(b[0]==0)
		{
			for(int i=0;i<n;i++)
			{
				if(b[i]!=i)
				{
					cnt++;
					swap(b[0],b[i]);
				index=i;
					break;
				}
			}
		}
	}
	cout<<cnt;
	return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值