P1118 [USACO06FEB]数字三角形Backward Digit Su…

题目描述

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:

    3   1   2   4
      4   3   6
        7   9
         16

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.

有这么一个游戏:

写出一个1~N的排列a[i],然后每次将相邻两个数相加,构成新的序列,再对新序列进行这样的操作,显然每次构成的序列都比上一次的序列长度少1,直到只剩下一个数字位置。下面是一个例子:

3 1 2 4

4 3 6

7 9 16 最后得到16这样一个数字。

现在想要倒着玩这样一个游戏,如果知道N,知道最后得到的数字的大小sum,请你求出最初序列a[i],为1~N的一个排列。若答案有多种可能,则输出字典序最小的那一个。

[color=red]管理员注:本题描述有误,这里字典序指的是1,2,3,4,5,6,7,8,9,10,11,12

而不是1,10,11,12,2,3,4,5,6,7,8,9[/color]

输入输出格式

输入格式:

两个正整数n,sum。

输出格式:

输出包括1行,为字典序最小的那个答案。

当无解的时候,请什么也不输出。(好奇葩啊)

输入输出样例

输入样例#1:  复制
4 16
输出样例#1:  复制
3 1 2 4

说明

对于40%的数据,n≤7;

对于80%的数据,n≤10;

对于100%的数据,n≤12,sum≤12345。

直接dfs会超时,要用杨辉三角。

大家可以自己在草稿纸上写一下,假设n为一个比较小的数(比如,按样例,4),设第一行的n个数分别为a,b,c,...(我这里是a,b,c,d),然后模拟加一下,就会发现sum是……

如果n为4,那么sum是a+3b+3c+d。

如果n为5,那么sum是a+4b+6c+4d+e。

如果n为6,那么sum是a+5b+10c+10d+5e+f。

看起来就是杨辉三角,用杨辉三角来剪枝就可以通过
#include <iostream>
#include <queue>
#include <algorithm> 
#include <string.h>
#include <stdio.h>
#include <vector>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace std;
int vis[20];
int n,m,flag=0,dp[20][20],ans[20][20],k,sum=0,yh[20][20];
vector <int> v;
void dfs(int x)
{
    if(sum>m)
    {
        return ;
    }
    if(flag==1)
    {
        return ;
    }
    if(x>n)
    {
        k=0;
        for(int i=0;i<v.size();i++)
        {
            dp[1][++k]=v[i];
        }
        for(int i=2;i<=k;i++)
        {
            for(int j=1;j<=k-i+1;j++)
            {
                dp[i][j]=dp[i-1][j]+dp[i-1][j+1];
            }
        }
        if(dp[k][1]==m)
        {
            for(int i=1;i<=k;i++)
            {
                cout<<dp[1][i];
                if(i!=k) cout<<" ";
            }
            exit(0);
        }
        memset(dp,0,sizeof(dp));
        return ;
    }
    for(int i=1;i<=n;i++)
    {
        if(vis[i]!=1)
        {
            vis[i]=1;
            v.push_back(i);
            sum+=yh[n][x]*v[x-1];
            //cout<<yh[n][x]*v[x-1]<<endl;
            dfs(x+1);
            sum-=yh[n][x]*v[x-1];
            vis[i]=0;
            v.pop_back();
        }
    }
}
int main(int argc, char *argv[]) {
    cin>>n>>m;
    memset(yh,0,sizeof(yh));
    for(int i=1;i<=n;i++)
    {
        yh[i][1]=1;
    }
    for(int i=2;i<=n;i++)
    {
        for(int j=2;j<=i;j++)
        {
            yh[i][j]=yh[i-1][j]+yh[i-1][j-1];
        }
    }
    dfs(1);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值