win7 + vs2015+ matlab2016a + python3.5安装matcaffe cpu版本

参考:

1. caffe-windows直接安装版---编译后的Release

2.安装Windows10 和环境下的caffe(新版)

3.win10+vs2015编译caffe的cpu debug版本、部署matcaffe

主要的方法参考文献3. 

当前caffe-windows仅支持python2.7和3.5

要注意的是:如果在安装时发现python接口有问题,可以去掉python的安装。 

if NOT DEFINED BUILD_PYTHON set BUILD_PYTHON=1 【设为0】
if NOT DEFINED BUILD_PYTHON_LAYER set BUILD_PYTHON_LAYER=1 【设为0】

注意release版本和debug版本的选择:

if NOT DEFINED CMAKE_CONFIG set CMAKE_CONFIG=   【设为Release】

如果需要在python3.6环境下设置python3.5,可以参考 《在现有的python环境下创建另一个python版本【亲测有效】

libraries_v140_x64_py35_1.1.0可以在csdn下载:https://download.csdn.net/download/happy_zzz_/10289346   

我自己装好的matcaffe: https://download.csdn.net/download/xiamentingtao/11255064,使用时不需要安装,直接使用,参考文献1. 

 

 

©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页