Gradle‘s dependency cache may be corrupt报错解决方案

最近使用Android Studio 4.0新建Android项目的时候,报了一个Gradle's dependency cache may be corrupt的错误,大概的意思就是网络请求超时,如果能翻墙,很好解决,如果没法翻墙,可以参考下面的几种方法。

手动下载Gradle

首先,我们可以从Gradle官网下载gradle文件,这里可以使用我提供的百度网盘的下载链接: https://pan.baidu.com/s/1iEd6kRtkREznFSgOHHKesA 密码: q2qf。然后将下载的包放到wrapper/dists目录下,如下图所示。
在这里插入图片描述
PS:当然也可以删除gradle-6.1.1-all文件,然后重新进行下载,这两种方式我试了下都可以。

修改Gradle版本

当然,我们还可以通过修改Gradle版本来解决问题,比如我之前本地有 5.6.4版本,那么先修改wrapper/gradle-wrapper.properties的脚本为。

distributionUrl=https\://services.gradle.org/distributions/gradle-5.6.4-all.zip

然后,开Android工程下的build.gradle文件,然后修改下面的gradle版本即可,如下所示。


buildscript {
    dependencies {
        classpath "com.android.tools.build:gradle:4.0.1"
    }
}

只需要将上面的4.0.1版本修改为3.5.2,如下所示。

   classpath "com.android.tools.build:gradle:3.5.2"

然后,重新编译一下项目即可。

xiangzhihong8 CSDN认证博客专家 HTTPS 前端框架 JavaScript
著有《React Native移动开发实战》、《Kotlin入门与实战》、《Weex跨平台开发与实战》、《React Native开发进阶》和《Flutter跨平台开发实战》,正努力完成《Android应用架构实战》
©️2020 CSDN 皮肤主题: 成长之路 设计师:Amelia_0503 返回首页
实付 9.90元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值