数据结构实验之链表六:有序链表的建立

Problem Description
输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。
Input
第一行输入整数个数N;
第二行输入N个无序的整数。
Output
依次输出有序链表的结点值。
Example Input
6
33 6 22 9 44 5
Example Output
5 6 9 22 33 44
 
 

#include <stdio.h>
#include <stdlib.h>
int k = 0, h = 0;
struct node
{
    int data;
    struct node *next;
};
struct node *creat(int n)
{
    struct node *head, *p, *tail;
    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;
    tail = head;
    int i;
    for(i = 1; i <= n; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d", &p->data);
        p->next = NULL;
        tail->next = p;
        tail = p;
    }
    return head;
};
void sort(struct node *head)
{
    struct node *p, *q, *r;
    p = head->next;
    if(p != NULL)
    {
        r = p->next;
        p->next =  NULL;
        p = r;
        while(p != NULL)
        {
            r = p->next;
            q = head;
            while(q->next != NULL && q->next->data <= p->data)
                q = q->next;
            p->next = q->next;
            q->next = p;
            p = r;
        }
    }
}
void display(struct node *head)
{
    struct node *p;
    p = head->next;
    while(p != NULL)
    {
        if(p->next != NULL)
            printf("%d ", p->data);
        else
            printf("%d\n", p->data);
        p = p->next;
    }
}
int main()
{
    struct node *head;
    int n;
    scanf("%d", &n);
    head = creat(n);
    sort(head);
    display(head);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值