数据结构实验之二叉树八:(中序后序)求二叉树的深度

Problem Description

已知一颗二叉树的中序遍历序列和后序遍历序列,求二叉树的深度。

Input

输入数据有多组,输入T,代表有T组数据。每组数据包括两个长度小于50的字符串,第一个字符串表示二叉树的中序遍历,第二个表示二叉树的后序遍历。

Output

输出二叉树的深度。

Example Input
2
dbgeafc
dgebfca
lnixu
linux
Example Output
4
3
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
    char data;
    struct node *lchild, *rchild;
};
struct node *build(char zx[], char hx[], int is, int hs, int n)
{
    struct node *root;
    int k, i;
    for(i = is; i < n + is; i++)
    {
        if(zx[i] == hx[hs + n - 1])
        {
            k = i;
            break;
        }
    }
    root = (struct node *)malloc(sizeof(struct node));
    root->data = hx[hs + n - 1];
    if(k == is)
        root->lchild = NULL;
    else
        root->lchild = build(zx, hx, is, hs, k - is);
    if(k == is + n - 1)
        root->rchild = NULL;
    else
        root->rchild = build(zx, hx, k + 1, k - is, n - 1 - k + is);
    return root;
};
int depth(struct node *root)
{
    int dl,dr;
    if(!root)
        return 0;
    else
    {
        dl = depth(root->lchild);
        dr = depth(root->rchild);
        if(dl > dr)
            return (dl + 1);
        else
            return (dr + 1);
    }
}
int main()
{
    struct node *root;
    char hx[100], zx[100];
    int n, t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%s %s", zx, hx);
        n = strlen(hx);
        root = build(zx, hx, 0, 0, n);
        printf("%d\n", depth(root));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值