中庸之道(一) UESTC - 977

中庸之道(一) UESTC - 977


Problem

读入三个整数aa、bb、cc,找出中间数并输出。
中间数是这样定义的:若三数不相等,则第2大的数是中间数;若有两个数相同,则最大数是中间数。

Input

有多组测试数据。输入的第一行是整数TT(0

Output

对应每组输入,输出这一行三个数的中间数。

Sample Input

3
2 3 4
12 35 12
13 13 10

Sample Output

3
35
13

ps:水题

代码如下:

#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<algorithm> 
#include<string.h> 
using namespace std; 
int main() {
    int t;
    scanf("%d", &t);
    while( t-- ) {
        int a[4];
        for(int i = 0; i <= 2; i++) scanf("%d", &a[i]);
        sort(a, a+3);
        if(a[0] == a[1]) printf("%d\n", a[2]);
        else printf("%d\n", a[1]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值