To The Max

To The Max
Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.


As an example, the maximal sub-rectangle of the array:
 0 -2 -7  0
 9  2 -6  2
-4  1 -4  1
-1  8  0 -2
is in the lower left corner:
 9  2
-4  1
-1  8
and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N2 integers separated by whitespace (spaces and newlines). These are the N2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1


8 0 -2
Sample Output

15

动态规划

题目的意思很简单,在一个矩阵里面找它的子矩阵,使得子矩阵数值之和到达最大。其实就是最大子段和问题在二维空间上的推广。先说一下一维的情况吧:设有数组a0,a1…an,找除其中连续的子段,使它们的和达到最大。假如对于子段:9 2 -16 2  temp[i]表示以ai结尾的子段中的最大子段和。在已知temp[i]的情况下,求temp [i+1]的方法是:

如果temp[i]>0 temp [i+1]= temp[i]+ai(继续在前一个子段上加上ai),否则temp[i+1]=ai(不加上前面的子段),也就是说 状态转移方程:

temp[i] = (temp[i-1]>0?temp[i-1]:0)+buf[i];

对于刚才的例子 temp: 9 11 -5 2,然后取temp[]中最大的就是一维序列的最大子段。求一维最大子段和的函数:

int getMax(int buf[100],int n)

{

    int temp[101],max=n*(-127);

    memset(temp,0,4*(n+1));

   

    for(int i=1;i<=n;i++)

    {

        temp[i] = (temp[i-1]>0?temp[i-1]:0)+buf[i];

        if(max<temp[i])

            max=temp[i];

    }

    return max;

}

下面扩展到二维的情况:考察下面题目中的例子:

0         -2  -7  0

9           2  -6  2

-4  1  -4   7

-1  8  0   -2

我们分别用i j表示起始行和终止行,遍历所有的可能:

for(i=1;i<=n;i++)

    for(j=i;j<=n;j++) {}

我们考察其中一种情况 i=2 j=4,这样就相当与选中了2 3 4三行,求那几列的组合能获得最大值,由于总是 2 3 4行,所以我们可以将这3行”捆绑”起来,变为求 4(9-4-1),11(8+2+1),-10(-6-4+0),7(7+2-2)的最大子段和,ok,问题成功转化为一维的情况!


#include <stdio.h>
#include "string.h"
#define MAXN (100+3)
int matrix[MAXN][MAXN];
int num[MAXN];
int getMax (int n) {
		int max = -127 * n;
		int i;
		int array[MAXN];
		array[0] = 0;	
		for (i = 1;i <= n;i++) {
				if (num[i] + array[i-1] > 0) {
					array[i] = num[i] + array[i-1];
				}else {
					array[i] = num[i];
				}
				if (max < array[i]) {
					max = array[i];
				}
		}
		return max;
}
int main () {
	int n,i,j,k,max,t;
	scanf ("%d",&n);
	for (i = 1;i <= n;i++) {
		for (j = 1;j <= n;j++) {
			scanf ("%d",&matrix[i][j]);
		}
	}
	max = -127 * n * n;
	for (i = 1;i <= n;i++) {
		memset (num,0,sizeof(num));
		for (j = i;j <= n;j++) {
			for (k = 1;k <= n;k++) {
				 num[k] = num[k] +  matrix[j][k]; 
			}
			t = getMax (n);
			if (t > max) {
				max = t;
			}
		}
	}
	printf ("%d\n",max);
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值