ACM刷题之HDU————Children’s Queue

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1170 Accepted Submission(s): 625
 
Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 
Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 
Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 
Sample Input
1
2
3
 
Sample Output
1
2
4
 
递推+大数
假设最后一位是男,那么会有f(n-1)种情况
假设最后一位是女,则倒数第二位必定是女,那么会有两种情况:
1、倒数第三位是男,那么就f(n-2)种情况
2、倒数第三位是女,那么就有f(n-4)种情况。

所以f(n)=f(n-1)+f(n-2)+f(n-4)
再配合JAVA的大数,这题就好了

下面是ac代码:
import java.math.BigInteger;
import java.util.Scanner;
import java.math.*;
import java.text.*;
public class Main{

	public static void main(String[] args) {
		// TODO 自动生成的方法存根
		Scanner cin=new Scanner(System.in);
		BigInteger[] child = new BigInteger[1002];
		child[1] = new BigInteger("1");
		child[2] = new BigInteger("2");
		child[3] = new BigInteger("4");
		child[4] = new BigInteger("7");
				
		int i = 0;
		for(i=5;i<=1000;i++){
			child[i] = child[i-1].add(child[i-2].add(child[i-4])) ;
		}
		
		while(cin.hasNext())   //等同于!=EOF
		{

			i=cin.nextInt();
			
			System.out.println(child[i]);
			
		}
	}

}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值