UVA10391 ZOJ1825 Compound Words【SET+暴力】(老师程序代码注释)

Compound Words


Time Limit: 5 Seconds      Memory Limit: 32768 KB


You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.


Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.


Output

Your output should contain all the compound words, one per line, in alphabetical order.
Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra


Sample Output

alien
newborn


Source: University of Waterloo Local Contest 1996.09.28

 

问题链接UVA10391 ZOJ1825 Compound Words

题意简述:一堆按照字典序排好的字符串,问有多少字符串是由其它两个字符串组成,输出这些字符串。

问题分析

采用穷举法来解决,数据规模不大就没有问题了。

将所有单词放入字符串集合中。

对所有单词s,将其分为所有可能的两个字符串t1和t2(s=t1+t2),查一下t1和t2是否都在集合中即可。

程序说明:(略)

 

AC的C++语言程序如下:

/* UVA10391 ZOJ1825 Compound Words */
 
#include <iostream>
#include <string>
#include <set>
 
using namespace std;
 
int main()
{
    string s, t1, t2;
    set<string> sset;//定义了一个s的集合  string是按照字典顺序排列的即ascll码表顺序 
	int len;
 
    while(cin >> s)
        sset.insert(s);
 
    for(set<string>::iterator iter=sset.begin(); iter!=sset.end(); iter++) {//迭代器 
        s = *iter
        len = s.length();
        for(int i=0; i<len-1; i++) {
            t1 = s.substr(0, i + 1);
            t2 = s.substr(i + 1, len - 1);
            if(sset.find(t1) != sset.end() && sset.find(t2) != sset.end()) {//用集合中的find方法判断在不在集合中,“匹配” 
                cout << s << endl;//不等于end说明找到了可以匹配的项了 
                break;
            }
        }
    }
 
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值