Ahui Writes Word (多重背包+二进制优化)

题目描述:

We all know that English is very important, so Ahui strive for this in order to learn more English words. To know that word has its value and complexity of writing (the length of each word does not exceed 10 by only lowercase letters), Ahui wrote the complexity of the total is less than or equal to C. Question: the maximum value Ahui can get. Note: input words will not be the same.

输入描述:

The first line of each test case are two integer N , C, representing the number of Ahui’s words and the total complexity of written words. (1 ≤ N ≤ 100000, 1 ≤ C ≤ 10000) Each of the next N line are a string and two integer, representing the word, the value(Vi ) and the complexity(Ci ). (0 ≤ Vi , Ci ≤ 10)

输出描述:

Output the maximum value in a single line for each test case.

测试样例:

样例输入 1

Copy

5 20

go 5 8

think 3 7

big 7 4

read 2 6

write 3 5

样例输出 1

Copy

15

思路:多重背包的二进制优化转化为01背包问题

AC代码:

#include <bits/stdc++.h>

using namespace std;
int dp[10005];
int v[10005];
int c[10005];
int s[15][15];

void csh() {
    memset(dp, 0, sizeof(dp));
    memset(v, 0, sizeof(v));
    memset(c, 0, sizeof(c));
    memset(s, 0, sizeof(s));
}

int main() {
    int n, cc;
    while (cin >> n >> cc) {
        int x, money;
        string s1;
        csh();
        for (int i = 1; i <= n; i++) {
            cin >> s1 >> x >> money;
            s[x][money]++;
        }
        int cnt = 0;
        for (int i = 1; i <= 10; i++) {
            for (int j = 1; j <= 10; j++) {
                if (s[i][j]) {
                    int k = 1;
                    while (s[i][j] >= k) {
                        v[cnt] = j * k;
                        c[cnt++] = i * k;
                        s[i][j] -= k;
                        k <<= 1;
                    }
                    if (s[i][j]) {
                        v[cnt] = j * s[i][j];
                        c[cnt++] = i * s[i][j];
                    }
                }
            }
        }
        for (int i = 0; i < cnt; i++) {
            for (int j = cc; j >= v[i]; j--) {
                dp[j] = max(dp[j], dp[j - v[i]] + c[i]);
            }
        }
        cout << dp[cc] << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值