487-3279

时间限制: 1000 ms  |  内存限制: 65535 KB
难度:2
描述

Businesses like to have memorable telephonenumbers. One way to make a telephone number memorable is to have it spell amemorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used tospell a word. When you get back to your hotel tonight you can order a pizzafrom Gino's by dialing 310-GINO. Another way to make a telephone numbermemorable is to group the digits in a memorable way. You could order your pizzafrom Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphenbetween the third and fourth digits (e.g. 888-1200). The keypad of a phonesupplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added andremoved as necessary. The standard form of TUT-GLOP is 888-4567, the standardform of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (Theydial the same number.) 

Your company is compiling a directory of telephone numbers from localbusinesses. As part of the quality control process you want to check that notwo (or more) businesses in the directory have the same telephone number. 

输入
The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.
输出
Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

样例输入

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

样例输出

310-1010 2
487-3279 4
888-4567 3

来源

POJ


电话号码可以以不同的形式出现,规范格式是xxx-xxxx,可以一些字母表示数字(不包括Q、Z),让找出给出的n个号码中重复出现的,按规范格式升序输出重复出现的电话号码和出现的次数。

注意:“No duplicates.”最后的'.'。

前导0也要输出来,如号码001-1233

还有就是cin输入时用c++可以过 用G++会超时,用scanf输入不会超时 |时间少了将近100MS。


#include<cstdio>
#include<cmath>
#include<map>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int g[100005];
int main()
{
    map<int ,int >m,q;
    int n;
    scanf("%d",&n);
    int r=0;
    m.clear();
    q.clear();
    memset(g,0,sizeof(g));
    while(n--)
    {
        char s[100];
        scanf("%s",s);
        int l=strlen(s);
        int f=10;
        int sum=0;
        for(int i=0;i<l;i++)
        {
            int a; int ff=0;
            if('0'<=s[i]&&s[i]<='9') a=s[i]-'0',ff=1;
            else if(s[i]=='A'||s[i]=='B'||s[i]=='C') a=2,ff=1;
            else if(s[i]=='D'||s[i]=='E'||s[i]=='F') a=3,ff=1;
            else if(s[i]=='G'||s[i]=='H'||s[i]=='I') a=4,ff=1;
            else if(s[i]=='J'||s[i]=='K'||s[i]=='L') a=5,ff=1;
            else if(s[i]=='M'||s[i]=='N'||s[i]=='O') a=6,ff=1;
            else if(s[i]=='P'||s[i]=='R'||s[i]=='S') a=7,ff=1;
            else if(s[i]=='T'||s[i]=='U'||s[i]=='V') a=8,ff=1;
            else if(s[i]=='W'||s[i]=='X'||s[i]=='Y') a=9,ff=1;
            if(ff==1){sum=sum*f+a;}
        }
        m[sum]++;
        if(m[sum]>1)g[r++]=sum;
    }
    if(r==0) printf("No duplicates.\n");
    else 
    {
      sort(g,g+r);
      for(int i=0;i<r;i++)
      {
        if(q[g[i]]==0)
            printf("%03d-%04d %d\n",g[i]/10000,g[i]%10000,m[g[i]]);//!!!注意前导0的输出
        q[g[i]]=1;
     }
   }
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值