Subsequence

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8645    Accepted Submission(s): 2900

Problem Description

There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.

 Input

There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.

 Output

For each test case, print the length of the subsequence on a single line.

 Sample Input

5 0 0

1 1 1 1 1

5 0 3

1 2 3 4 5

Sample Output

5
4

找到一个子序列,保证子序列中的最大值和最小值差值>=m&&<=k,求这样的子序列最长长度。

单调递增队列的维护方式:

1 3 5 2 4 (编号1~5)

i=1:1进队列。

此时队列里:1

i=2:a[2]>a[1],2进队列。

此时队列里:1,2

i=3:a[3]>a[2],3进队。

此时队列里:1,2,3

i=4:a[4]<a[3],3出队,a[4]<a[2],2出队,a[4]>a[1],4进队

此时队列里:1,4

i=5:a[5]>a[4],5进队

此时队列里:1,4,5.

递减的规则一样,这就是单调队列的维护方式。(进队的都是编号,不是数本身)

这道题 分别维护一个递增,递减的单调队列。·

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
int a[maxn],q1[maxn],q2[maxn];
int main()
{
    int n,m,k,rear1,front1,rear2,front2,ans,now;
    while(~scanf("%d%d%d",&n,&m,&k))
    {
        rear1=rear2=front1=front2=0;now=1,ans=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            while(rear1>front1&&a[q1[rear1-1]]>a[i]) rear1--;//q1递增
            while(rear2>front2&&a[q2[rear2-1]]<a[i]) rear2--;//q2递减
            q1[rear1++]=i; q2[rear2++]=i;

            while(rear1>front1&&rear2>front2&&a[q2[front2]]-a[q1[front1]]>k)
            {
                if(q2[front2]<q1[front1]) now=q2[front2++]+1;
                else now=q1[front1++]+1;
            }
            if(rear1>front1&&rear2>front2&&a[q2[front2]]-a[q1[front1]]>=m)
                ans=max(ans,i-now+1);
        }
        printf("%d\n",ans);
    }
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值