【微软编程一小时】题目1 : Arithmetic Expression

时间限制: 2000ms
单点时限: 200ms
内存限制: 256MB

描述

Given N arithmetic expressions, can you tell whose result is closest to 9?

输入

Line 1: N (1 <= N <= 50000).
Line 2..N+1: Each line contains an expression in the format of "a op b" where a, b are integers (-10000 <= a, b <= 10000) and op is one of addition (+), subtraction (-), multiplication (*) and division (/). There is no "divided by zero" expression.

输出

The index of expression whose result is closest to 9. If there are more than one such expressions, output the smallest index.

样例输入
4
901 / 100
3 * 3
2 + 6
8 - -1
样例输出
2
每次都很傻逼地用 == 去判断String相等,每次都吃亏都不长记性!叫你不长记性!
import java.util.Scanner;


public class Main {

	static int InversionCount ;
	
	public static void main(String[] args) 
	{
		int T,t;
		Scanner jin = new Scanner(System.in);
		T = jin.nextInt();
		jin.nextLine();
		
		int ret = T+1;
		double max_abs = Double.MAX_VALUE;
		
		for (t = 1; t <= T; t++) {

	
			String line = jin.nextLine();
			String[] argStrings = line.split(" ");
			
			//System.out.println(argStrings.length);
			
			double a = Double.parseDouble(argStrings[0]);
			double b = Double.parseDouble(argStrings[2]);
							
			double op_ret ;
			if (argStrings[1].equals("+")) {
				op_ret = a + b;
			}
			else if (argStrings[1].equals("-")) {
				op_ret = a - b;
			}
			else if (argStrings[1].equals("*")) {
				op_ret = a * b;
			}
			else op_ret = a / b;
			
			
			if (Math.abs(op_ret - 9) < max_abs) {
				max_abs = Math.abs(op_ret - 9);
				ret = t;
			}
		}
		System.out.println(ret);
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值