HDU 4133 反素数

 

StrangeStandard

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 70    Accepted Submission(s): 31


Problem Description
Nowadays, WHUACMer use a strange standard to evaluate a natural number.The evaluating value of a natural number is the amount of it’s divisors.If a number m has bigger evaluating value than all the numbers smaller than it, we call it a good number. Now give you a number n, find the maximum good number which is not bigger than n.
 

Input
The first line contains a single integer T(T<=10), indicating the number of test cases.
For each test case,there is only one line which only contains one number n(1 <= n <= 2 000 000 000)
 

Output
For each test case,output the case number first,then output the maximum good number which is not bigger than n.
 

Sample Input
  
  
1 1000
 

Sample Output
  
  
Case #1: 840
 

Source
 

Recommend
lcy
 
很明显的反素数搜索。
照着模板写就行了。。
 
我的代码:
#include<stdio.h>

__int64 prime[16]={2,3,5,7,11,13,17,19,23,29,31,37,41,43,47};
__int64 n,cnter,ans;

void dfs(__int64 cur,__int64 cnt,__int64 power,__int64 sub)
{
    __int64 i;
    if(cur>n)
        return;
    if(cnt==cnter&&cur<ans)
        ans=cur;
    if(cnt>cnter)
    {
        ans=cur;
        cnter=cnt;
    }
    __int64 p=prime[sub];
    for(i=1;i<=power;i++)
    {
        if(cur*p>n)
            break;
        dfs(cur*p,cnt*(i+1),i,sub+1);
        p=p*prime[sub];
    }
}

int main()
{
    int t,T;
    scanf("%d",&T);
    for(t=1;t<=T;t++)
    {
        scanf("%I64d",&n);
        cnter=0,ans=0;
        dfs(1,1,50,0);
        printf("Case #%d: %I64d\n",t,ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值