HDU 1013 数根 规律

http://acm.hdu.edu.cn/showproblem.php?pid=1013

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24
39
0

Sample Output

6
3

题目大意:计算一个数的数根,即计算该数的每位数之和,若大于10,则递归计算,小于10则输出。(不懂看样例)

思路:递归处理字符串即可。虽然我写的是循环的。当然也有dalao发现了这道题的规律,%%%。

循环:

#include<iostream>
#include<cstdio>
#include<stack>
#include<cmath>
#include<cstring>
#include<queue>
#include<set>
#include<algorithm>
#include<iterator>
#define INF 0x3f3f3f3f
typedef long long ll;
typedef unsigned long long ull;
using namespace std;

string s;
char c[1005];
void solve();

int main()
{
	while(cin>>s&&s!="0")
		solve();
	return 0;
}

void solve()
{
	int temp;
	for(int i=0;i<s.size();i++)
		c[i]=s[i];
	int MAX=s.size();
	while(1)
	{
		temp=0;
		for(int i=0;i<MAX;i++)
		{
			temp+=c[i]-48;
		}
		if(temp<10)
			break;
		for(int i=0;;)
		{
			c[i++]=temp%10+48;
			temp/=10;
			if(temp==0)
			{
				MAX=i;
				break;
			}
		}
	}
	printf("%d\n",temp);
}

找规律:(手写了几个 还真是这么回事orz) 

#include<iostream>
#include<cstdio>
#include<stack>
#include<cmath>
#include<cstring>
#include<queue>
#include<set>
#include<algorithm>
#include<iterator>
#define INF 0x3f3f3f3f
typedef long long ll;
typedef unsigned long long ull;
using namespace std;

string s;

int main()
{
	while(cin>>s&&s!="0")
	{
		int temp=0;
		for(int i=0;i<s.size();i++)
			temp+=s[i]-48;
		printf("%d\n",(temp-1)%9+1);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值