迷宫问题

POJ - 3984

定义一个二维数组: 

int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

可以用数组模拟队列,然后走过的所有结点都可以保存下来,每走到下一个结点用pre数组记录下一个结点是从哪个结点到达的

 

#include<iostream>

#include<cstdio>

#include<queue>

#include<stack>

using namespace std;

int board[6][6],vis[6][6],l,r,pre[1000];

struct node

{

int x,y,dis;

};

node qu[1000];

int mov[4][2] = {{1,0},{0,1},{-1,0},{0,-1}};

inline int bfs()

{

while(l < r)

{

node nown = qu[++l];

for(int i = 0;i < 4;++i)

{

node nextn;

nextn.x = nown.x + mov[i][0];

nextn.y = nown.y + mov[i][1];

nextn.dis = nown.dis + 1;

if(nextn.x <= 5 && nextn.x >= 1 && nextn.y <= 5 && nextn.y >= 1 && board[nextn.x][nextn.y] == 0 && !vis[nextn.x][nextn.y])

{

vis[nextn.x][nextn.y] = 1;

qu[++r] = nextn;

pre[r] = l;

if(nextn.x == 5 && nextn.y == 5)

return r;

}

}

}

}

int main()

{

for(int i = 1;i <= 5;++i)

for(int j = 1;j <= 5;++j)

cin >> board[i][j];

node n1;

n1.x = 1;

n1.y = 1;

n1.dis = 0;

vis[1][1] = 1;

l = r = 0;

pre[1] = 0;

qu[++r] = n1;

int ans = bfs();

stack<node> st;

while(ans)

{

st.push(qu[ans]);

ans = pre[ans];

}

while(!st.empty())

{

node nn = st.top();

st.pop();

printf("(%d, %d)\n",nn.x-1,nn.y-1);

}

return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值